LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-25-2009, 02:06 AM   #1
RattleSn@ke
Member
 
Registered: Oct 2007
Location: Netherlands, ZH
Posts: 32

Rep: Reputation: 15
Problem building 32bit RPM on 64bit host


Hi,

I've been working on this for 3 days now and can't find any solution any where on the internet. (at least not one that works for me)

I try to build a 32bit PHP RPM on a CentOS5.3 86x64 host. Every post I read indicates that it should be possible, but not for me.

I issue the following command (found somewhere in a post):
Code:
CC='gcc -m32' linux32 rpmbuild -ba --target=i386 SPECS/php-5.3.0.spec
Then it starts:
Code:
Building target platforms: i386
Building for target i386
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.43870
+ umask 022
+ cd /home/onno/rpm/BUILD
+ cd /home/onno/rpm/BUILD
+ rm -rf php-5.3.0
+ /usr/bin/bzip2 -dc /home/onno/rpm/SOURCES/php-5.3.0.tar.bz2
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd php-5.3.0
++ /usr/bin/id -u
+ '[' 501 = 0 ']'
++ /usr/bin/id -u
+ '[' 501 = 0 ']'
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .

(..SNIP..)

+ pushd build-cgi
~/rpm/BUILD/php-5.3.0/build-cgi ~/rpm/BUILD/php-5.3.0
+ build --enable-force-cgi-redirect --enable-pcntl --with-imap=shared --with-imap-ssl --enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex --with-gd=shared --enable-bcmath=shared --enable-dba=shared --with-db4=/usr --with-xmlrpc=shared --with-ldap=shared --with-ldap-sasl --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config --enable-dom=shared --with-dom-xslt=/usr --with-dom-exslt=/usr --with-pgsql=shared --with-snmp=shared,/usr --enable-soap=shared --with-xsl=shared,/usr --enable-xmlreader=shared --enable-xmlwriter=shared --enable-fastcgi --enable-pdo=shared --with-pdo-odbc=shared,unixODBC,/usr --with-pdo-mysql=shared,/usr --with-pdo-pgsql=shared,/usr --with-pdo-sqlite=shared,/usr --with-pdo-dblib=shared,/usr --enable-json=shared --enable-zip=shared --with-readline --with-pspell=shared --with-mcrypt=shared,/usr --with-mhash=shared,/usr --with-tidy=shared,/usr --with-mssql=shared,/usr
+ mkdir Zend
+ cp ../Zend/zend_language_parser.c ../Zend/zend_language_parser.h ../Zend/zend_language_scanner.c ../Zend/zend_language_scanner.h ../Zend/zend_ini_parser.c ../Zend/zend_ini_parser.h ../Zend/zend_ini_scanner.c ../Zend/zend_ini_scanner.h Zend
+ ln -sf ../configure
+ CFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ export CFLAGS
+ CXXFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ export CXXFLAGS
+ FFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
+ export FFLAGS
+ ./configure --host=x86_64-redhat-linux-gnu --build=x86_64-redhat-linux-gnu --target=i386-redhat-linux --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-libdir=lib --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-rpath --without-pear --with-bz2 --with-curl --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --enable-gd-native-ttf --with-t1lib=/usr --without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-png --with-expat-dir=/usr --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --with-kerberos --enable-ucd-snmp-hack --with-unixODBC=shared,/usr --enable-memory-limit --enable-shmop --enable-calendar --enable-dbx --enable-dio --without-mime-magic --without-sqlite --with-libxml-dir=/usr --with-xml --with-system-tzdata --enable-force-cgi-redirect --enable-pcntl --with-imap=shared --with-imap-ssl --enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex --with-gd=shared --enable-bcmath=shared --enable-dba=shared --with-db4=/usr --with-xmlrpc=shared --with-ldap=shared --with-ldap-sasl --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config --enable-dom=shared --with-dom-xslt=/usr --with-dom-exslt=/usr --with-pgsql=shared --with-snmp=shared,/usr --enable-soap=shared --with-xsl=shared,/usr --enable-xmlreader=shared --enable-xmlwriter=shared --enable-fastcgi --enable-pdo=shared --with-pdo-odbc=shared,unixODBC,/usr --with-pdo-mysql=shared,/usr --with-pdo-pgsql=shared,/usr --with-pdo-sqlite=shared,/usr --with-pdo-dblib=shared,/usr --enable-json=shared --enable-zip=shared --with-readline --with-pspell=shared --with-mcrypt=shared,/usr --with-mhash=shared,/usr --with-tidy=shared,/usr --with-mssql=shared,/usr
configure: creating cache ../config.cache
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking build system type... x86_64-redhat-linux-gnu
checking host system type... x86_64-redhat-linux-gnu
checking target system type... i386-redhat-linux-gnu
checking for x86_64-redhat-linux-gnu-cc... gcc -m32
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
error: Bad exit status from /var/tmp/rpm-tmp.72849 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.72849 (%build)
With the following command I tried I get the same error:
Code:
rpmbuild -ba --target=i386 SPECS/php-5.3.0.spec
Some rpms of interest(?)
# rpm -qa |grep "cc"
libgcc-4.1.2-44.el5
libgcc-4.1.2-44.el5
psacct-6.3.2-44.el5
pam_ccreds-3-5
pam_ccreds-3-5
ccid-1.3.8-1.el5
gcc-c++-4.1.2-44.el5
gcc-4.1.2-44.el5

Hopefully someone can and will assist me in this.

TIA.
Onno.
 
Old 09-25-2009, 07:54 AM   #2
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 17,863

Rep: Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598
Quote:
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
I'd start by checking that log as the msg suggests
 
Old 09-25-2009, 08:45 AM   #3
RattleSn@ke
Member
 
Registered: Oct 2007
Location: Netherlands, ZH
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by chrism01 View Post
I'd start by checking that log as the msg suggests
You're right, but I first was unable to find it but now I found it.

Code:
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59.  Invocation command line was

  $ ./configure --host=x86_64-redhat-linux-gnu --build=x86_64-redhat-linux-gnu --target=i386-redhat-linux --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --cache-file=../config.cache --with-libdir=lib --with-config-file-path=/etc --with-config-file-scan-dir=/etc/php.d --disable-debug --with-pic --disable-rpath --without-pear --with-bz2 --with-curl --with-exec-dir=/usr/bin --with-freetype-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --enable-gd-native-ttf --with-t1lib=/usr --without-gdbm --with-gettext --with-gmp --with-iconv --with-jpeg-dir=/usr --with-openssl --with-png --with-expat-dir=/usr --with-pcre-regex=/usr --with-zlib --with-layout=GNU --enable-exif --enable-ftp --enable-magic-quotes --enable-sockets --enable-sysvsem --enable-sysvshm --enable-sysvmsg --enable-track-vars --enable-trans-sid --enable-yp --enable-wddx --with-kerberos --enable-ucd-snmp-hack --with-unixODBC=shared,/usr --enable-memory-limit --enable-shmop --enable-calendar --enable-dbx --enable-dio --without-mime-magic --without-sqlite --with-libxml-dir=/usr --with-xml --with-system-tzdata --enable-force-cgi-redirect --enable-pcntl --with-imap=shared --with-imap-ssl --enable-mbstring=shared --enable-mbstr-enc-trans --enable-mbregex --with-gd=shared --enable-bcmath=shared --enable-dba=shared --with-db4=/usr --with-xmlrpc=shared --with-ldap=shared --with-ldap-sasl --with-mysql=shared,/usr --with-mysqli=shared,/usr/bin/mysql_config --enable-dom=shared --with-dom-xslt=/usr --with-dom-exslt=/usr --with-pgsql=shared --with-snmp=shared,/usr --enable-soap=shared --with-xsl=shared,/usr --enable-xmlreader=shared --enable-xmlwriter=shared --enable-fastcgi --enable-pdo=shared --with-pdo-odbc=shared,unixODBC,/usr --with-pdo-mysql=shared,/usr --with-pdo-pgsql=shared,/usr --with-pdo-sqlite=shared,/usr --with-pdo-dblib=shared,/usr --enable-json=shared --enable-zip=shared --with-readline --with-pspell=shared --with-mcrypt=shared,/usr --with-mhash=shared,/usr --with-tidy=shared,/usr --with-mssql=shared,/usr

## --------- ##
## Platform. ##
## --------- ##

hostname = repos64.linux.argeweb.nl
uname -m = i686
uname -r = 2.6.18-128.el5
uname -s = Linux
uname -v = #1 SMP Wed Jan 21 10:41:14 EST 2009

/usr/bin/uname -p = unknown
/bin/uname -X     = unknown

/bin/arch              = i686
/usr/bin/arch -k       = unknown
/usr/convex/getsysinfo = unknown
hostinfo               = unknown
/bin/machine           = unknown
/usr/bin/oslevel       = unknown
/bin/universe          = unknown

PATH: /usr/kerberos/bin
PATH: /usr/local/bin
PATH: /bin
PATH: /usr/bin
PATH: /home/onno/bin

## ----------- ##
## Core tests. ##
## ----------- ##

configure:1775: creating cache ../config.cache
configure:1856: checking for egrep
configure:1866: result: grep -E
configure:1871: checking for a sed that does not truncate output
configure:1927: result: /bin/sed
configure:2030: checking build system type
configure:2048: result: x86_64-redhat-linux-gnu
configure:2056: checking host system type
configure:2070: result: x86_64-redhat-linux-gnu
configure:2078: checking target system type
configure:2092: result: i386-redhat-linux-gnu
configure:2228: checking for x86_64-redhat-linux-gnu-cc
configure:2254: result: gcc -m32
configure:2317: checking for C compiler version
configure:2320: gcc -m32 --version </dev/null >&5
gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-44)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2323: $? = 0
configure:2325: gcc -m32 -v </dev/null >&5
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre --with-cpu=generic --host=x86_64-redhat-linux
Thread model: posix
gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)
configure:2328: $? = 0
configure:2330: gcc -m32 -V </dev/null >&5
gcc: '-V' must come at the start of the command line
configure:2333: $? = 1
configure:2356: checking for C compiler default output file name
configure:2359: gcc -m32 -O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables   conftest.c  >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2362: $? = 1
configure: failed program was:
| /* confdefs.h.  */
|
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_BUGREPORT ""
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:2401: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-redhat-linux-gnu
ac_cv_build_alias=x86_64-redhat-linux-gnu
ac_cv_env_CC_set=set
ac_cv_env_CC_value='gcc -m32'
ac_cv_env_CFLAGS_set=set
ac_cv_env_CFLAGS_value='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_CXXCPP_set=
ac_cv_env_CXXCPP_value=
ac_cv_env_CXXFLAGS_set=set
ac_cv_env_CXXFLAGS_value='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
ac_cv_env_CXX_set=
ac_cv_env_CXX_value=
ac_cv_env_F77_set=
ac_cv_env_F77_value=
ac_cv_env_FFLAGS_set=set
ac_cv_env_FFLAGS_value='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=set
ac_cv_env_build_alias_value=x86_64-redhat-linux-gnu
ac_cv_env_host_alias_set=set
ac_cv_env_host_alias_value=x86_64-redhat-linux-gnu
ac_cv_env_target_alias_set=set
ac_cv_env_target_alias_value=i386-redhat-linux
ac_cv_host=x86_64-redhat-linux-gnu
ac_cv_host_alias=x86_64-redhat-linux-gnu
ac_cv_prog_CC='gcc -m32'
ac_cv_prog_egrep='grep -E'
ac_cv_target=i386-redhat-linux-gnu
ac_cv_target_alias=i386-redhat-linux
lt_cv_path_SED=/bin/sed

## ----------------- ##
## Output variables. ##
## ----------------- ##

ALLOCA=''
AR=''
AWK=''
CC='gcc -m32'
CFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
CONFIGURE_COMMAND=' './configure'  '--host=x86_64-redhat-linux-gnu' '--build=x86_64-redhat-linux-gnu' '--target=i386-redhat-linux' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--with-t1lib=/usr' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--with-mysql=shared,/usr' '--with-mysqli=shared,/usr/bin/mysql_config' '--enable-dom=shared' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--enable-fastcgi' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-pdo-dblib=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--with-readline' '--with-pspell=shared' '--with-mcrypt=shared,/usr' '--with-mhash=shared,/usr' '--with-tidy=shared,/usr' '--with-mssql=shared,/usr''
CONFIGURE_OPTIONS=' '--host=x86_64-redhat-linux-gnu' '--build=x86_64-redhat-linux-gnu' '--target=i386-redhat-linux' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-libdir=lib' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--enable-gd-native-ttf' '--with-t1lib=/usr' '--without-gdbm' '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-expat-dir=/usr' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--without-mime-magic' '--without-sqlite' '--with-libxml-dir=/usr' '--with-xml' '--with-system-tzdata' '--enable-force-cgi-redirect' '--enable-pcntl' '--with-imap=shared' '--with-imap-ssl' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-gd=shared' '--enable-bcmath=shared' '--enable-dba=shared' '--with-db4=/usr' '--with-xmlrpc=shared' '--with-ldap=shared' '--with-ldap-sasl' '--with-mysql=shared,/usr' '--with-mysqli=shared,/usr/bin/mysql_config' '--enable-dom=shared' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--enable-soap=shared' '--with-xsl=shared,/usr' '--enable-xmlreader=shared' '--enable-xmlwriter=shared' '--enable-fastcgi' '--enable-pdo=shared' '--with-pdo-odbc=shared,unixODBC,/usr' '--with-pdo-mysql=shared,/usr' '--with-pdo-pgsql=shared,/usr' '--with-pdo-sqlite=shared,/usr' '--with-pdo-dblib=shared,/usr' '--enable-json=shared' '--enable-zip=shared' '--with-readline' '--with-pspell=shared' '--with-mcrypt=shared,/usr' '--with-mhash=shared,/usr' '--with-tidy=shared,/usr' '--with-mssql=shared,/usr''
CPP=''
CPPFLAGS=''
CXX=''
CXXCPP=''
CXXFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
DEBUG_CFLAGS=''
DEFS=''
ECHO='echo'
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP='grep -E'
EXEEXT=''
EXPANDED_BINDIR=''
EXPANDED_DATADIR=''
EXPANDED_EXTENSION_DIR=''
EXPANDED_LIBDIR=''
EXPANDED_LOCALSTATEDIR=''
EXPANDED_PEAR_INSTALLDIR=''
EXPANDED_PHP_CONFIG_FILE_PATH=''
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=''
EXPANDED_SYSCONFDIR=''
EXTENSION_DIR='/usr/lib/php/modules'
EXTRA_INCLUDES=''
EXTRA_LDFLAGS=''
EXTRA_LDFLAGS_PROGRAM=''
EXTRA_LIBS=''
F77=''
FFLAGS='-O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables'
ICU_CONFIG=''
INCLUDES=''
INCLUDE_PATH=''
INLINE_CFLAGS=''
INSTALL_IT=''
KRB5_CONFIG=''
LDFLAGS=''
LEMON=''
LIBOBJS=''
LIBS=''
LIBTOOL=''
LN_S=''
LTLIBOBJS=''
LTP=''
LTP_GENHTML=''
MYSQL_INCLUDE=''
MYSQL_LIBS=''
MYSQL_MODULE_TYPE=''
NATIVE_RPATHS=''
OBJEXT=''
OCI8_DIR=''
OCI8_ORACLE_VERSION=''
OCI8_SHARED_LIBADD=''
ODBC_INCLUDE=''
ODBC_LFLAGS=''
ODBC_LIBS=''
ODBC_TYPE=''
OPENSSL_INCDIR_OPT=''
PACKAGE_BUGREPORT=''
PACKAGE_NAME=''
PACKAGE_STRING=''
PACKAGE_TARNAME=''
PACKAGE_VERSION=''
PATH_SEPARATOR=':'
PDO_MYSQL_MODULE_TYPE=''
PDO_OCI_DIR=''
PDO_OCI_SHARED_LIBADD=''
PDO_OCI_VERSION=''
PEAR_INSTALLDIR='/usr/share/pear'
PHP_INSTALLED_SAPIS=''
PHP_LDFLAGS=''
PHP_LIBS=''
PHP_VERSION='5.3.0'
PHP_VERSION_ID='50300'
PKG_CONFIG=''
PROG_SENDMAIL=''
RANLIB=''
RE2C=''
SED='/bin/sed'
SHELL='/bin/sh'
SHLIB_DL_SUFFIX_NAME=''
SHLIB_SUFFIX_NAME=''
SNMP_CONFIG=''
STRIP=''
YACC=''
ZEND_EXTRA_LIBS=''
abs_builddir='/home/onno/rpm/BUILD/php-5.3.0/build-cgi'
abs_srcdir='/home/onno/rpm/BUILD/php-5.3.0'
ac_ct_AR=''
ac_ct_CC=''
ac_ct_CXX=''
ac_ct_F77=''
ac_ct_RANLIB=''
ac_ct_STRIP=''
bindir='/usr/bin'
build='x86_64-redhat-linux-gnu'
build_alias='x86_64-redhat-linux-gnu'
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='redhat'
datadir='/usr/share'
exec_prefix='/usr'
host='x86_64-redhat-linux-gnu'
host_alias='x86_64-redhat-linux-gnu'
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='redhat'
includedir='/usr/include'
infodir='/usr/share/info'
libdir='/usr/lib'
libexecdir='/usr/libexec'
localstatedir='/var'
mandir='/usr/share/man'
oldincludedir='/usr/include'
php_abs_top_builddir='/home/onno/rpm/BUILD/php-5.3.0/build-cgi'
php_abs_top_srcdir='/home/onno/rpm/BUILD/php-5.3.0'
prefix='/usr'
program_prefix=''
program_suffix='NONE'
program_transform_name='s,x,x,'
sbindir='/usr/sbin'
sharedstatedir='/usr/com'
sysconfdir='/etc'
target='i386-redhat-linux-gnu'
target_alias='i386-redhat-linux'
target_cpu='i386'
target_os='linux-gnu'
target_vendor='redhat'

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""

configure: exit 77
So I see some failures now:
configure:2330: gcc -m32 -V </dev/null >&5
gcc: '-V' must come at the start of the command line

configure:2359: gcc -m32 -O2 -g -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status

But what is now exactly causing the problem? I think it's due the missing of some package but I don't have any clue which one.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
32bit qemu image on 64bit host? Yalla-One Slackware 14 08-25-2009 05:18 PM
building 32bit app on 64bit system nori Linux - Software 1 07-20-2007 01:10 PM
Problem installing 32bit software onto RH 64bit ES bboy-mass Linux - Server 0 01-30-2007 06:36 AM
rpm 32bit or 64bit detection rh724 Linux - General 2 11-16-2006 02:01 PM
can 64bit processor run both 64bit and 32bit computers? DJOtaku Linux - General 4 09-08-2005 08:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration