-   Linux - Software (
-   -   Privoxy and tor (

z3nith 10-01-2005 05:21 AM

Privoxy and tor
I have installed both packages and each works ok on its own. My problem arises when i append the privoxy config file with:

forward-socks4a / .

I get nothing but a 503 error from privoxy. Here is the last entry in privoxy's logfile:
Oct 01 21:16:30 Privoxy(-1219277904) Request:
Oct 01 21:16:30 Privoxy(-1208788048) Request: cgi call
Oct 01 21:16:30 Privoxy(-1208788048) Request: crunch!

Here is the last entry in tor.log:
Oct 01 21:16:08.033 [notice] Tor opening new log file.
Oct 01 21:16:08.033 [notice] Initialized libevent version 1.1a using method epoll
Oct 01 21:16:13.477 [notice] Tor has successfully opened a circuit. Looks like it's working.

I noticed i had to be root to enter /var/log/tor (don't know if it matters or not).

I've spent a week on this so far and i won't sleep until i pin it. Can someone point me in the right direction to get this going?

free_ouyo 10-01-2005 01:39 PM

Privoxy and tor

Here is the link to privoxy faq about error 503.

Also, when modifying the config file, you need to stop privoxy and after modification, restart privoxy.

z3nith 10-01-2005 10:31 PM

Thanks free_ouyo,

I have seen that FAQ and many many others. I am not using zonealarm and even after stopping, appending, restarting i still get the said error. There are plenty of tutorials out there on setting these two up, they are all the same, i have followed them verbadim, but still no joy.

I installed them both from the default repository for FC4. Any other suggestions or comments?

All times are GMT -5. The time now is 02:48 PM.