-   Linux - Software (
-   -   Printing via VPN (

GrateWhiteSmurf 05-05-2011 03:33 PM

Printing via VPN
I'm running a print server using CUPS on a computer running Ubuntu 9.04. I have several computers using it quite nicely, but I need to add a laptop to this mix. I work at a University which has a VPN. All wireless connections must go through the VPN, the laptop uses wireless. So here's my problem: the laptop cannot see the printer, or maybe the printer computer cannot see the laptop. I'm not sure which.

The laptop is running Windows 7, but I can print just fine with a computer running Windows Vista, so I don't think this is an issue.

My server's /etc/cups/cupsd.conf contains the following:

DefaultAuthType Basic
<LogLevel warning
SystemGroup lpadmin
# Allow remote access
Port 631
Listen /var/run/cups/cups.sock
# Share local printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAddress @LOCAL
DefaultAuthType Basic
<Location />
# Allow shared printing...
Order allow,deny
Allow ???
Allow ???
Allow ???

The ??? are the IP addresses of the computer's on my network. I've tried several versions of what I believe to be the laptop's IP or hostname including" *, and the IP of the router. I also tried the hostname of another computer that should be in my local network but it did not work either.

I'm testing to see that it's working by simply going to <IP>:631 in a browser. Once I can see the CUPS menu there I figure I should be able to use the printer, that's how it worked with Vista.

GrateWhiteSmurf 05-05-2011 03:56 PM

I just ran ipconfig on the laptop. I was surprised when I saw no IPv4 address, only and IPv6 address for the VPN address. I don't know how to use this, or even if I can.

GrateWhiteSmurf 05-06-2011 09:40 AM

Today I've brought my netbook to see if I can get it working. It is running Ubuntu 10.10 Netbook Remix. I'm having the same issues, so I'm pretty sure the use of Windows is not the problem.

All times are GMT -5. The time now is 06:13 PM.