-   Linux - Software (
-   -   Printing Nightmare : Cups on Slackware (

daleman 04-12-2005 01:38 AM

Printing Nightmare : Cups on Slackware
I really hope some one can help on this one because it is driving me batty.

I am developing or rather rewriting an application to run on linux (the original was DOS based, written in Clipper). Outside of my control, the chosen language has been FlagShip, a unix based system, which runs a large percentage of Clipper Code.

Anyway, started off on Red Hat 9, but for a number of reasons, it was decided to change to Slackware 10. This has been working well until my current showstopper.

The FlagShip Printing System is simple, as i understand it, based around lpd. I was able to set up CUPS on Red Hat to emulate LPD (CUPS-LPD, launched from XINETD) and all way well.

On my Slackware box, however, (after I enabled the parallel port) I was able to install a local DOT MATRIX printer, with a RAW print queue, and send it a test page.

BUT, when I attempt the following : lp -d locdot /etc/passwd

I get the following errors :

Status Information, attempt 1 of 3:
sending job 'root@thebitch+666' locdot @localhost
connecting to 'localhost', attempt 1
cannot open connection to localhost - No such file or directory
Make sure the remote host supports the LPD protocol
Waiting 10 seconds before retry

Problem is, I am not even aiming at a remote host - this attempts and fails 3 times - bang I am stumped.

I imagine there is some stupid, arcane file that I have to alter, but i simply have no idea where to look. So if anyone can point me in the right direction, I would be eternally grateful.

Andrew Benton 04-13-2005 11:14 AM

When you installed slack did you do the default install that installs everything? If so you'll need to remove the lprng stuff and just use cups, like so

daleman 04-13-2005 06:02 PM

Thanks Andrew

I did simply recreate the symbolic links as advised by another helpful fella, and voila, problem solved, but another has reared its ugly head.

I have configured cupsd.conf to the best of my ability, but somehow, the server will not allow remote connections. I have set up a valid BrowseAddress and the print queue is visible from remote machines... but upon actually sending jobs to it, they "vanish"

I suspect that I have to configure something in cupsd.conf on the server to permit connections, but I cannot fathom what.

I tried Listen ServerIP:631 , but that just seemed to break cups....

Any ideas

All times are GMT -5. The time now is 09:46 AM.