LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-12-2005, 11:31 AM   #1
bioagentice
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10
Posts: 25

Rep: Reputation: 15
Angry pppd timeout before pppd interface could start!


I didn't have any luck out of the last post, so either no body can help me in this arduous feat, or i just didnt supply enough information, so i spent a half an hour back in linux writing all this stuff down on a bank statement ( it was the closest thing i could write on ). When i launch the ppp interface in KDE i have all of my user name and password stuff entered in, phone numbers are all correct and all that (or maybe not, but well talk about that in a minute) so i then click connect... here is what the active log says is going on:

:ATZ
:OK
:ATM1L1
:OK
:CONNECT57600


at the bottom of the log it gives a current action which says

:STARTING PPPD

After about 30 secs it gives me an error message that says:

"TIMEOUT EXPIRED WHILE WAITING FOR PPP INTERFACE TO COME UP!"

I read the help file on the Kppp program and it said that i might be able to find some help in the details file that is produced after the program times out, i opened that and this is what it had to say:

"<todays date/time>: LCP: Timeout occurred while sending configuration request"


--Linux Diagnosis (Just Guessing)--
"Remote system could not answer to the config-request, please contact your service provider"

Called them and they had no idea what was wrong, they said that it was something on my end of the line and that they couldn't help me, then she hung up on me, what kind of customer service is that?

Anyway, i hope i can get some help from the all knowing LinuxQuestions gurus that walk among us, thanks to all
 
Old 03-13-2005, 03:07 AM   #2
s_araj
Member
 
Registered: Feb 2005
Location: Mumbai, India
Distribution: FC 2 | Ubuntu 5.04 | SuSE 9.3
Posts: 46

Rep: Reputation: 15
I believe you need to check out your hardwares like cable, cards etc. This is a possibility that they are in bad shape.
 
Old 03-13-2005, 04:31 AM   #3
bioagentice
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10
Posts: 25

Original Poster
Rep: Reputation: 15
i figured out what the problem was, i knew that the hardware wasnt the problem, they are all 2 days old/ brand new, it turns out that my domain name was typed in worng, i know, stupid user error, but now i have the problem of the browser unexpectedly quiting as Linux likes to put it, do we have any idea what causes that problem? i read linuxants faq page, and there isnt really anything there to help that one out, so i am yet agian, relying on the wisdom of the infamous linux gurus
 
Old 03-26-2005, 12:54 PM   #4
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Rep: Reputation: 23
bioagentice, what do you mean by your "domain name was typed in wrong?" I am having the same problem. Did you mean to say your username was typed in wrong? So far I have tried to solve my problem by running depmod -a, and by re-installing the ppp and kde network packages, none of which worked. Here is the error message I get in kppp:

Mar 26 11:06:44 mikeylin pppd[5205]: LCP: timeout sending Config-Requests
Mar 26 11:06:44 mikeylin pppd[5205]: Receive serial link is not 8-bit clean:
Mar 26 11:06:44 mikeylin pppd[5205]: Problem: all had bit 7 set to 0

This all started when I tried to install a new modem, which turned out to be a Winmodem with a driver that did not support my motherboard. I put the old modem back in the machine, and that is when I started getting the pppd timeout error messages in kppp.
Mike.
 
Old 03-26-2005, 03:19 PM   #5
veerain
Senior Member
 
Registered: Mar 2005
Location: Earth bound to Helios
Distribution: Custom
Posts: 2,524

Rep: Reputation: 319Reputation: 319Reputation: 319Reputation: 319
Mar 26 11:06:44 mikeylin pppd[5205]: LCP: timeout sending Config-Requests
Mar 26 11:06:44 mikeylin pppd[5205]: Receive serial link is not 8-bit clean:
Mar 26 11:06:44 mikeylin pppd[5205]: Problem: all had bit 7 set to 0

It's because your modem hasn't connected to other side at all or the ppp protocol has not started on ISP side. Try to make sure your connect script is correct and try connecting to your ISP through minicom
Type AT&F
ATDT132276273 (Your Phone Number)
 
Old 03-26-2005, 03:48 PM   #6
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Rep: Reputation: 23
Thanks for the suggestions contusion. The modem does connect to the ISP long before I get the pppd timeout message, I can see it in the kppp log window. I don't think the problem is with the ISP because I can still connect on Windows. I wouldn't know how to check the connect script, but I never edited it, and I would think if anything was wrong with it, re-installing the ppp package would have fixed it.
Mike.
 
Old 03-27-2005, 12:24 PM   #7
mscole
Member
 
Registered: Nov 2004
Location: Florida
Distribution: Slackware 14.1
Posts: 119

Rep: Reputation: 23
Ok, I solved my problem after a lot of fishing around on various forums and lists. Unfortunately I've forgotten exactly where I found the solution, so I can't give proper credit, but here is how I did it. These error messages mean the modem is not set to 8N1:

Mar 26 11:06:44 mikeylin pppd[5205]: LCP: timeout sending Config-Requests
Mar 26 11:06:44 mikeylin pppd[5205]: Receive serial link is not 8-bit clean:
Mar 26 11:06:44 mikeylin pppd[5205]: Problem: all had bit 7 set to 0

I don't know how the settings got changed, but to get them back to default I copied the initialization string from minicom and pasted it into kppp under "configure - modem - modem commands - initialization string 1:." After that kppp was able to connect and log on to my ISP. Actually, it would probably be ok just to change that string from "ATZ" to whatever command restores factory defaults, but I don't know it because it's not in my modem's owner's manual. Hope this helps someone.
Mike.

Last edited by mscole; 03-27-2005 at 12:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LCP timeout - pppd problems leobert Linux - Hardware 3 01-28-2005 08:54 AM
pppd: how to bring up an interface? J_Szucs Linux - Networking 2 08-08-2004 09:02 AM
pppd - use fixed interface? fzzy Linux - Networking 0 03-26-2004 09:29 AM
pppd died: pppd options error (exit code 2 taveirac Linux - Networking 1 02-12-2004 11:17 AM
pppd died: pppd options error (exit code 2) ianwest Linux - Newbie 2 07-31-2002 09:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration