LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Postfix: cant send email from my Windows pc using my postfix mailserver (https://www.linuxquestions.org/questions/linux-software-2/postfix-cant-send-email-from-my-windows-pc-using-my-postfix-mailserver-659566/)

elvisious 07-31-2008 01:32 PM

Postfix: cant send email from my Windows pc using my postfix mailserver
 
Hi,

Ik have installed a mailserver with: Postfix, Dovecot and fetchmail.

Most of all works fine:

I can fetch my mail with fetchmail on my server.
I can send mail with Postfix on my server.
I can get my mail with Outlook on my Windows system from my server.

The only that doesn't work is that I can not send mail from my Windows system using my mail server...

:confused:

When I do a port scan on my mail server all nessesary port are open (110, 143) but port 25 is closed. Isn't this the port that Outlook uses to send mail?

( When I stop Postfix and I start Sendmail I have the same problem )

Can somebody help me?

Greetz
Dion

elvisious 07-31-2008 04:42 PM

I now have installed Squirrelmail too and its working OK. Squirrelmail is installed on the mailserver.
So the problem is still the same: How can I use my mailserver from my Windows machine to send email?

billymayday 07-31-2008 05:14 PM

Have a look in the maillogs for what happens. I'll bet it's the mynetworks section in main.cf, but post the output of "postconf -n"

Mr. C. 08-01-2008 01:10 AM

This sounds like the mail server is listening only on the loopback interface.

What is the output of

netstat -aln --tcp

or iptables is blocking the port.

iptables -L

elvisious 08-01-2008 01:40 PM

Hi

Thanks! You both where right:

I put this line in /etc/postfix/main.cf:

Code:

mynetworks = 192.168.100.0/24, 127.0.0.0/8
And then I gave the command:

Code:

#postfix reload
Nothing happens. So I read my /var/log/maillog:
Code:

postfix/master[20133]: warning: service smtp: ignoring inet_interfaces change
postfix/master[20133]: warning: to change inet_interfaces, stop and start Postfix

And then I did this:

Code:

#postfix stop
#postfix start

;)

Mr. C. 08-01-2008 02:03 PM

Setting mynetworks does not change inet_interfaces. In fact, the log message indicates you also changed inet_interfaces. This was the variable change that was required.

mynetworks tells postfix what mail clients to consider as local and hence trusted.

elvisious 08-01-2008 02:09 PM

Yes. You are right again. I did some things and I wanted to put the things I did in this forum and then I forgot the inet_interfaces thing.

I did this in the main.cf:
Code:

inet_interfaces = all

billymayday 08-01-2008 03:57 PM

So is it working now?

elvisious 08-01-2008 07:01 PM

Yes

:cool:


All times are GMT -5. The time now is 01:11 PM.