LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   POP3 Imap Problems (https://www.linuxquestions.org/questions/linux-software-2/pop3-imap-problems-254528/)

Cynthia Blue 11-13-2004 08:46 PM

POP3 Imap Problems
 
My postfix is working fine, when I send mail to my intended email address, it appears in webmin okay, so I know incomming mail is alright.

However, I cannot pop nor IMAP my server. I'm on SuSe 9.1 and attemping to get this going. I tried courier imap, no go, tried cyrus no go. I'm attemping just plain old IMAP.

When I try to pop the server, I get this error:
Command Stream end of file whiel reading line user=??? host=myhost [ip]

Okay, so looking into that, that error appears just to be my mail server saying that the client is trying to connect, and not disconnecting properly.

The error I get on outlook from where I am popping, is
There was a problem logging onto your mail server. Your User Name was rejected. Account 'POP' Server blah blah ... ERR unknown AUTHORIZATION state command.

sooo.. is that telling me I don't have my pop/imap set up correctly to allow users to log in? And if so, where would I find the file where I can change that? Can't be main.cf, as that is a postfix file. I've changed the /etc.xinetd/imap file so it is allowed... but I don't see any other configuration files with IMAP. HELP!

Thanks.

Electro 11-13-2004 09:27 PM

Probably a firewall problem, so check your iptables. Also check hosts.deny and hosts.allow. In hosts.deny make sure you have ALL: ALL and in hosts.allow you have imap:all, smtp:all, pop3:all (I think that is what they are called listed in services file).

I think you need to add a few users to the desire mail servers (imap or pop3).

Cynthia Blue 11-13-2004 10:55 PM

I hadn't turned the firewall on at all. And my ports are all open, so I don't think it's a firewall issue.

I checked the hosts.allow file and there is a bunch in there, but it's all commented. I added the lines

imapd : ALL
pop3d : ALL

restart xinetd? I did so, still I get the same errors. Maybe I'm not putting those in there right. And SMTP is already working fine so I didn't include that.

hosts.deny is pretty sparse, it just has
http-rman : ALL EXCEPT LOCAL in there.

You know, the more I think about it, the more I realize that no matter what IMAP or POP version I'm using, I'm getting the same darn errors. So it's gotta be something like this. Thanks for your help.


All times are GMT -5. The time now is 01:49 AM.