LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-06-2004, 06:29 PM   #1
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Rep: Reputation: 15
Poor sound quality in KDE apps (using arts)


What is wrong, I have poor sound quality in all KDE apps I use (JuK, Kaffeine, Noatun and so on..)
When I try listening some music, I can hear it ok but there's all the time strange gurgling sound in the background which is very annoying.

The strange thing is that music plays perfectly with non-KDE apps like XMMS even if I'm using arts plugin with it. I'm using ALSA and kernel is 2.6.7
 
Old 07-06-2004, 06:44 PM   #2
amosf
Senior Member
 
Registered: Jun 2004
Location: Australia
Distribution: Mandriva/Slack - KDE
Posts: 1,672

Rep: Reputation: 46
I tend to turn arts off. Esp since it seems to be responsible for lockups with crossover and winex...
 
Old 07-06-2004, 06:58 PM   #3
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Original Poster
Rep: Reputation: 15
I don't think the problem is now arts itself because XMMS works well with arts output plugin.
 
Old 07-07-2004, 12:43 AM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Try going into the control center under sound and see if increasing the buffer a bit helps.
 
Old 07-07-2004, 06:46 AM   #5
Mikessu
Member
 
Registered: Sep 2003
Distribution: Gentoo, FreeBSD 5.1
Posts: 122

Original Poster
Rep: Reputation: 15
Thanks for answering but increasing buffer didn't fix the problem.

Any other suggestions?
 
Old 10-20-2004, 08:22 AM   #6
legolin
Member
 
Registered: Dec 2003
Location: munich
Distribution: Fedora Core 4
Posts: 141

Rep: Reputation: 15
hi, now i'm having the same problem... but i won't even play good using xmms and arts plugin... everytime arts is beeing used, the sound is somehow bad...

is there a diferent mixer one could use?

thankx,


leg
 
Old 10-20-2004, 08:53 AM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by legolin
hi, now i'm having the same problem... but i won't even play good using xmms and arts plugin... everytime arts is beeing used, the sound is somehow bad...

is there a diferent mixer one could use?

thankx,


leg
You can get a different output plugin. There likely is one already for OSS, but often the one for ALSA is a download. It was in the Mandrake repository and also in Gentoo's portage, so you should be able to get it for your distro (is it Fedora? Or Debian? - surely its apt-gettable)
 
Old 10-20-2004, 11:44 AM   #8
legolin
Member
 
Registered: Dec 2003
Location: munich
Distribution: Fedora Core 4
Posts: 141

Rep: Reputation: 15
hi,

i with oss and alsa it works fine... but i whanted to have the mixed version (arts) working good.


because i use licq and i whant to hear when somebody sends me a message and so on... if i use alsa, at the end of the music i'll have a lot of icq sounds at the same time.... this isn't good


thankx


leg
 
Old 10-20-2004, 01:35 PM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Right. That's understandable. Is XMMS the only app that has real problems with aRTs?
 
Old 11-06-2004, 07:08 PM   #10
RoaCh Of DisCor
Member
 
Registered: Apr 2004
Location: Washington State
Distribution: SuSE 9.3 / Slackware-Current
Posts: 701

Rep: Reputation: 30
I had that same problem with fedora. I removed KDE..and reinstalled it. That fixed it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor sound quality in linux? Jilted Linux - General 6 09-27-2004 07:59 AM
poor sound quality slackware_03 Linux - Distributions 10 09-23-2004 05:17 PM
ALSA poor sound quality hamish Linux - Hardware 3 04-09-2004 06:00 AM
poor sound quality MDK 10 gurty Mandriva 2 03-24-2004 09:11 PM
two soundcards and poor sound quality joemamma Linux - Hardware 0 02-24-2003 12:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration