LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   PolicyKit and Hal problem (https://www.linuxquestions.org/questions/linux-software-2/policykit-and-hal-problem-520394/)

TongueTied 01-18-2007 01:32 AM

PolicyKit and Hal problem
 
For some reason, policykit stopped working and now wont start. As a result, Hal also wont start as policykit is a dependency. The error I get when trying to start it in Yast is that it failed and returned error 7. Any ideas what happened. Where can I find out what 7 stands for in reference to policykit? I can't seem to find an error in the normal log I would look in for other issues (/var/log/messages or /var/log/warn etc.). Any suggestions?

I'm using openSuSE 10.2.

TongueTied 01-19-2007 08:26 PM

Found the problem and solved. The problem developed when I tried to install the rpm for MySQL 5.0.27 from MySQL site.

One of the problems that resulted from HAL and policykit not running is that I couldn't mount the CD drive (manually or with automount). So, without a clever solution, I wanted to reinstall haldaemond dbus and policykit but since I couldn't mount the CD, I couldn't reinstall. The solution was to add opensuse ftp site to the installation source and reinstall haldaemon, dbus and policykit from there.


All times are GMT -5. The time now is 05:35 AM.