LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-27-2008, 04:30 AM   #1
arshzia
LQ Newbie
 
Registered: Apr 2008
Posts: 27

Rep: Reputation: 15
plz. help me out of this problem


i am installing gtk+-2.12.9, to install this library it was asking dependencies atk,cairo,glib,pango,tiff,jpeg. i have installed all the packages but even though iam getting the the problem


checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met:

Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.12.3
Requested 'pango >= 1.17.3' but version of Pango is 1.14.9

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.



actually iam new to linux plz.help me
 
Old 04-27-2008, 04:43 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
why are you trying to install gtk2 from source? i'll bet money that you've no reason to need to do this, and probably even have it installed already from a binary package. give us the reasons for installing gtk2 in the first place and let's tackle them... if you're trying to install another package which requires gtk2 then you' normally just install the gtk2-devel package or an equivalent for your distro in an rpm, deb etc...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
plz sort the problem krisri Linux - Kernel 3 12-18-2007 10:47 AM
plz help with dhcp problem :( JustDesi Linux - Wireless Networking 1 07-31-2004 01:54 AM
plz plz solve my route mapping problem nedian123 Linux - Networking 1 07-12-2004 10:41 PM
PCMCIA problem, plz help! at_the_gates Linux - General 2 06-25-2004 12:38 AM
wx-config problem strange problem plz help glacier1985 Linux - Software 4 07-26-2003 06:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration