LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-27-2005, 02:09 PM   #1
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
please translate my dmesg output for me...


I've been trying to get ndiswrapper working with my D-Link DWL G122 usb dongle. I've had loads of help on other parts of this forum - see link below


http://www.linuxquestions.org/questi...5&pagenumber=1

so please don't give me general ndiswrapper advice or point me to Google or WIKI pages - I've read them all!!


Anyway, I got ndiswrapper correctly installed, with correct drivers, but still it doesn't work. I'm trying to work out why but being a newbie, I need a little help. Plese can anyone tell me what the dmesg seen below means please:



So my ndiswrapper is all installed with correct drivers, but the D-Link light still doesn't light up and I can't get it to work.

Anyway, I did

modprobe ndiswrapper

and this sat thinking about it for a minute or two and then finished - but still didn't light up my D-link. I then did

dmesg

and got a very odd readout. This is what I don't understand.... (I am a newbie still!):


[root@localhost adrian]# dmesg
ing address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3


It continued to repeat the above message over 240 times and then finished with:


usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
usb 4-2: reset high speed USB device using address 3
ndiswrapper (usb_reset_port:633): usb_reset_device() = -19
ndiswrapper (ndiswrapper_add_one_usb_dev:312): Windows driver couldn't initialize the device (C0000001)
ndiswrapper: probe of 4-2:1.0 failed with error -22
usbcore: registered new driver ndiswrapper
usb 4-2: USB disconnect, address 3
usb 4-2: new high speed USB device using address 5
[root@localhost adrian]#



OK, so why didn't it work?

According to another thread, I'm using the correct drivers, and I have now tried with the XP drivers from the CD that came with the device AND with the drivers that I downloaded from the D-Link website.

I've reinstalled, rebooted, tried with 10.1 Community, upgraded to 10.1 Official, done everything, but still no luck.

What does the above dmesg output mean folks???

Thanks for looking!!!
 
Old 07-27-2005, 02:20 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
Which drivers are you using? As unhelpful as it is, it does look like bad windows drivers.
 
Old 07-27-2005, 03:26 PM   #3
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
It looks like that to me too! But these are the ones from both my CD AND from the website!

NetRTUSB.inf
rt25u98.sys
rt2500usb.sys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dmesg output cranium2004 Linux - Newbie 1 01-27-2005 02:03 AM
Please translate pstree output and inform how to manipulate it Frybyte Linux - General 1 06-19-2004 09:26 PM
please help! error in dmesg output mickey1980 Linux - General 2 06-02-2004 10:23 PM
very strange dmesg output salparadise Linux - Software 6 04-08-2004 11:34 AM
dmesg output safrout Slackware 6 05-18-2003 11:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration