-   Linux - Software (
-   -   PLease help me! No sound in JRE (

ButterflyMelissa 08-02-2010 06:20 AM

PLease help me! No sound in JRE

I use JRE 1.6.2_20 to play Runescame, but I get no sound. Can anyone please eehlp?


Sys : FC12/JRE 1.6.0 20/Firefox
(years later - sorry for my wining...)

John VV 08-03-2010 02:36 AM

i could start listing off things to try.
BUT What have you done and tried already ?
and did sound work before ??? now .

craigevil 08-03-2010 02:38 AM

Works just fine here.
Debian sid 2.6.32 kernel Firefox 3.6.8 and in Chrome 6.0.472.14 dev
Java(TM) Plug-in 1.6.0_21
alsa 1.0.21

Works with the 2.6.35 kernel and alsa 1.0.23 as well.

ButterflyMelissa 08-04-2010 05:15 AM


Both of ya: BIG tnx for a reaction...

Ok, here's a short digest of the quest I did:
- installed FC12
- installed the JRE plugin from Sun/Oracle in /usr/java/jre1.6.0_21/
- made a symlink to the libjavaplugin in /home/T01/.mozilla/plugin (home folder of the user), owner and group were transfered to "T01" (the user) using chown
- tinkered with the alternatives next, as the Sun JRE was not visible in the plugins-pane of Firefox...
- I added the Sun JRE in the libjavaplugin entry of the alternatives, set it to active (the bullet) with priority 1000 (the max I could set it to)
- also checked the read-perms of the folder (/usr/java/jre1.6.0_21/plugin/i386/ns7/ and x-perms were available, execute should have been possible...
- installed FC13 and went tru the whole song again...

I does work on FC10, there I did (about) the same - give or take some things that did'nt needed to be done as they did'nt have any impact anyway...

What I do notice is that system-configure-sound does not show ALSA as a device, but only the hardware - no virtual device as I do have in FC10...

Distro trouble? Broken stuff (I did update the FC13 - after a netinstall - it was an absolute fresh install)

BTW - what is the life cycle of your distros? Fedora has one of about six months now, and having to do that dance over and over again seems a bit of a waste of time, my projects dont wait...


And all wellness to you!

(still crazy after all those years)

craigevil 08-04-2010 11:02 AM

Take a look at

Also see

Debian Stable is usually released about every 2 yrs,. You can use the backports and volatile repos to get newer packages. Stable only gets security and the rare bug fixes.

Personally I run Debian unstable it is more a rolling release, with continual updates. I have had the same install for 6 years, haven't had to reinstall so far.
I do apt-get update;apt-get dist-upgrade daily to stay updated.

John VV 08-04-2010 04:14 PM

you do know that fedora has the default java-icetea installed bu default ?
and by installing the sun java on top of a already installed java that messed up the currently installed java

i am not running fedora right now BUT
that is not the location of the already installed java in fedora
it is in the "alternitaves " folder


I does work on FC10, there I did (about) the same
fedora changes SO VERY fast
that what worked in 10 might not work in 13
3 newer versions

the java install changed i think in fedora 11

ButterflyMelissa 08-04-2010 05:15 PM


John : thanks, this means I have to re-learn how to install Java. A "mistake" I made was to assume Fedora would have some continuity in the way it's to be treated, it seems it does not. I looked at arch linux, and debian, maybe a change of distro is in order. Sadly, I really like(d) Fedora...
craigevil : big tnx for the boost here, I have the (hopefully wrong) impression that Linux is open, yet not acessible. I do hope I'm wrong...I dread the day I HAVE to revert to windows...
Lemme have a look at debian...
Eh, I'm so lost, I dont know if I have to change distro, or re-learn how to install Java. Maybe an uninstall of the icetea?

Hey, it's about midnite...and I just got of work...I'm rambling...

Wellness and goodnite good people!


ButterflyMelissa 08-04-2010 05:27 PM

Hi again,

Wow, craigevil, the links you gave are just the pick-me-up I needed right now.
I'll try that out asap...but now, the little munchkinks tell me to have a nap first...

Tnx, dudes!!

(happy again...)

John VV 08-04-2010 05:36 PM

yep that is fedora it changes very fast
the Mjm pages are one of the best help pages for fedora
so is the fedora docs

ButterflyMelissa 08-09-2010 06:47 AM


Ok, so, here's what I did: I installed Debian :D . Smooth install, be it that some servers were not accessible (at the time) - I tried out the runescape, and still get no sound...

Using Lenny, kernel 2.6.26-2-686, latest JRE (1.6.0_21) and Iceweasel...

But, all in all, Debian seems like the way forward for me...if it has a lifespan that exceeds that one of Fedora by a couple of years.

In case you're wondering, this is what lshw found:

description: Space-saving Computer
product: Pentium(R) 4 processor 2666 MHz
vendor: Hewlett-Packard
serial: czc3280v5z
width: 32 bits
capabilities: smbios-2.3 dmi-2.3 smp-1.4 smp

and a whole slew more, there's a 250Gb SATA disk and 1.5 Gb memory...

Something MUST be possible here...

Man, there goes the project...again.

Tnx for some insight - if possible, guys.



craigevil 08-09-2010 07:22 AM

Sounds more like you need to get your soundcard working properly.
take a look at Trouble shooting ALSA on Debian - :

For the Java web browser plugin, install either the free icedtea-gcjwebplugin (Lenny) or icedtea6-plugin (Squeeze) package,
or the <non-free> sun-java6-plugin package. For other Java programs, you can install the default-jre package to get a Java runtime;
use "apt-cache search java-virtual-machine" to see other implementations. The best options are probably openjdk-6-jre or sun-java6-jre (non-free).

$ apt-cache policy sun-java6-plugin
Installed: 6.21-1
Candidate: 6.21-1
Version table:
*** 6.21-1 0
500 sid/non-free Packages
100 /var/lib/dpkg/status

Update Iceweasel to the version in the backports repo.I would also update the kernel to the backports one.

ButterflyMelissa 08-11-2010 08:55 AM


I just (simply) re-installed Debian added Pulseaudio and I have system sounds - quite a bit of them...but, no sound in the JRE. :S

I used the Sun JDK 1.6.0 21 and the JRE from that set.

Are we looking at a security problem here?

Tnx 4 yur hlp!!! :D


ButterflyMelissa 08-13-2010 10:57 AM

By the way - anyone else had this problem? And found a way to fix this? I'd like to head/read from you...and your solution. I'm still slaying in silence here (in Runescape) and I would like to hear the agony of the ones I slay...

Ok, I just want to hear sounds in Java...:D




ButterflyMelissa 08-14-2010 05:17 PM

Well, for one I dont think it is a security problem...and I cannot install JMF...

If any-bo-dy has something clever/usefull to add, please do...thanks


ButterflyMelissa 08-21-2010 08:24 AM


In the (bleak) hope of some answer/solution...I had the same effect on a PC where Runescape does work. The VLC was still active, and I did not get any (ambient) sounds in the game.

I re-installed PulseAudio on the Debian machine but without any difference.
Can it be that the system-sounds get in the way? Something else is in the way? How do I figure out what wants to make sound and thus hogs the speakers - so to speak?



All times are GMT -5. The time now is 05:37 PM.