LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2004, 07:28 PM   #1
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Rep: Reputation: 15
please help me I'm in dependency hell


Hello---

I'm in dependency hell now. Please tell me how I can fix this.
Here is my take on what has happened so far. Please feel free to correct me.

I want to install qdvdauthor
http://qdvdauthor.sourceforge.net

the ./configure yields this :

*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+**+*+*+*+
*+*+ Please wait while building configurator +*+
*+*+ your graphical configuration application +*+
*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+*+**+*+*+*+
qt
************************************************
** Error, could not find moc. **
** **
** Please make sure your PATH environment **
** is set correctly. **
************************************************

but find / -name moc doesn't give any results. maybe I don't have moc on my system ?

I read that my version of qt is too old :

(am I totally wrong and qt is only for Kde and I'm running gnome ?)

[root@yoruban baronsam]# rpm -q qt
qt-3.1.1-6

so I try this :

[root@yoruban baronsam]# rpm -ivh qt-3.3.3-8.i386.rpm
warning: qt-3.3.3-8.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
/etc/ld.so.conf.d is needed by qt-3.3.3-8
libXinerama.so.1 is needed by qt-3.3.3-8
libstdc++.so.6 is needed by qt-3.3.3-8
libstdc++.so.6(CXXABI_1.3) is needed by qt-3.3.3-8
libstdc++.so.6(GLIBCXX_3.4) is needed by qt-3.3.3-8

so I figure I need a newer version of glibc :

[root@yoruban baronsam]# rpm -U glibc-2.3.4-0.20040318.1.i386.rpm
error: Failed dependencies:
glibc-misc = 6:2.3.4-0.20040318.1 is needed by glibc-2.3.4-0.20040318.1
glibc = 2.3.2 is needed by (installed) glibc-devel-2.3.2-27.9.7
/usr/bin/getent is needed by (installed) stunnel-4.04-3

so maybe with an older version :

[root@yoruban baronsam]# rpm -U glibc-2.3.3-58.chk.i386.rpm
error: Failed dependencies:
glibc-common = 2.3.3-58.chk is needed by glibc-2.3.3-58.chk
shadow-utils < 2:4.0.3-20 conflicts with glibc-2.3.3-58.chk
nscd < 2.3.3-52 conflicts with glibc-2.3.3-58.chk
libc.so.6(GLIBC_PRIVATE) is needed by (installed) nscd-2.3.2-27.9.7
glibc = 2.3.2 is needed by (installed) glibc-devel-2.3.2-27.9.7

even worse ! I'm stuck !

So anybody who could tell me where to find moc, or what I'm doing wrong, would be greatly appreciated.

Thanks very much,

--Sam
 
Old 11-05-2004, 07:36 PM   #2
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
why dont u use a package manager (like apt , urpmi , yum , ....)?

what distro are u using ?
 
Old 11-05-2004, 07:47 PM   #3
mAineAc
Member
 
Registered: Nov 2000
Location: Hermon, ME
Distribution: slackware
Posts: 201

Rep: Reputation: 30
you could try installing this:
http://distro.ibiblio.org/pub/linux/...ces/moc/2.0.1/
 
Old 11-05-2004, 07:58 PM   #4
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Original Poster
Rep: Reputation: 15
Thanks for answering !

I'm using redhat 9

I don't know if it includes a package manager, I know it doesn't include yum.

Which package manager would you recommend ?

Thanks,

--Sam
 
Old 11-05-2004, 08:49 PM   #5
baronsam
Member
 
Registered: Oct 2003
Posts: 44

Original Poster
Rep: Reputation: 15
I've installed yum, we'll see how it works out.

Thank you both for your help.

--Sam
 
Old 11-05-2004, 09:33 PM   #6
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
u could use yum
there is apt for redhat but i think yum will be better for redhat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dependency hell riseringseeker Linux - Newbie 3 09-22-2004 01:57 PM
Dependency Hell :-( AMMullan Linux - Software 5 03-27-2004 10:51 PM
Is this what they mean by dependency hell? john_walsh54 Linux - Software 1 10-10-2003 07:52 AM
Dependency hell !!! lub0 Linux - Software 5 09-26-2003 08:17 AM
Dependency Hell Time Lord Mandriva 2 09-09-2003 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration