LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   playing wmv files (https://www.linuxquestions.org/questions/linux-software-2/playing-wmv-files-252225/)

ankscorek 11-07-2004 08:36 PM

playing wmv files
 
what latest codec is required to play wmv files..
at present i tried playing on VLC media player and there was no video output ..only audio output..
i tried playing on helix media player and real player 10...but it goes to check for updates...
so what do i have to update...
can a link also be proided...:Pengy:

reddazz 11-07-2004 09:12 PM

you need win32 codecs from xine nightly page or from mplayer's website . They need to go into /usr/lib/win32 if you don't use an rpm package.

ankscorek 11-08-2004 04:37 AM

i downloaded the codec and installed it some other directory ..
though i linked it up with /usr/local/lib/win32
but no use....
is it probably that i have installed the media player b4 installing the codec

theonebeyond 11-08-2004 05:12 AM

Which distro are you using?
Because i heared, that for example SuSE compiles their version of xine so that you cannot play .wmv and stuff...

Don't know if it is true,.. for my SuSE 8.2 it is... was :-)

Maybe you could try to check for that.

Greetings, Sascha

reddazz 11-08-2004 05:39 AM

sometimes it's best to compile xine-lib (libxine) and mplayer from source when you have installed the win32 codecs, libdvdcss and other libraries because the binaries distributed by some distros are crippled or just don't work right.

ankscorek 11-08-2004 08:14 PM

i downloaded the essential package ..do i require to download all the codecs..?

jev-bird 11-08-2004 08:27 PM

For xine it does not matter when you install it. Just grab the win32 codecs from mplayer's site and unpack them anywhere, your home directory even. Then open up xine and put the settings tab on "Master of Universe" and navigate to codecs section and enter the exact location where your windows codecs are, restart xine and voila.

Commando464 11-08-2004 08:36 PM

If you are using SuSE, then you have to uninstall xine that came with the distro.

Then download and install the packages here

http://cambuca.ldhs.cetuc.puc-rio.br/xine/

Instructions are there also.

This is what i had to do to make it all work on SuSE.

ankscorek 11-10-2004 02:28 AM

i am using redhat 9..i downloaded all the codecs from the mplayer site ..installed them in /usr/lib/win32..but it is still not playing those files...

theonebeyond 11-10-2004 02:43 AM

don't know hjow redhat handles all this stuff, but I think it is possible that you have to reinstall like in Commando464's posting.

Don't worry... if it is like that.. it isn't too hard to manage, even for a newbie. Actually it is one of the first things I ever installed on Linux.

carboncopy 11-10-2004 09:02 PM

Additional problem to the thread
 
I can play wmv files with xine and mplayer on my Slackware 10.0. But I only get audio. No video. What could be the problem?

Neutron1998 11-10-2004 10:18 PM

Kaffiene by default plays .wmv just fine.

carboncopy 11-10-2004 10:34 PM

I fixed the problem. Just install the daily build win32 library from the website pointed above.

Thanks.

ankscorek 11-13-2004 08:09 AM

thanx people the installation in /usr/local/lib/win32 and later on ammending my /etc/ld.so.conf ....followed by
#ldconfig got my xine going


All times are GMT -5. The time now is 01:35 AM.