-   Linux - Software (
-   -   Playing Video in Mozilla (

wvdf96a 08-07-2004 08:09 PM

Playing Video in Mozilla
I'm using Fedora Core 2 and running Mozilla 1.7.2.
I have the following J2RE installed: Java(TM) Plug-in Blackdown-1.4.2-rc1
I have installed RealPlayer10 for Linux and it works great in standalone
mode (when I bring it up from the command line).
But, I cannot get Mozilla to call it for some video clip url's

When I right-click Preferences on a link for a video clip e.g. in the USAToday Life section
I can see that the link is of the form: javascript:OpenVideobigLife(somefile.rm)
But, when I select it Mozilla brings up some kind of RealPlayer Ad picture that says I need to download RealPlayer. JavaScript doesn't seem to know to call the RealPlayer10 that
I have installed.

However, if I paste the "file.rm" directly into my browser address, it brings
up RealPlayer10 and plays the clip.
FYI: I have specified RealPlayer10 as the helper application for playing .rm files.

Is there something wrong w/ my Java setup? How can I get Mozilla to
just bring up my RealPlayer10 and play the clip?

Any help appreciated.


futhark 08-08-2004 08:08 PM

I have not installed Real but I'm familiar with plugins in general. I think your plugin may not be setup correctly.

To see which plugins are setup in your browser, enter this url:

The Real plugin should be listed there. If it's not, then see what is the contents of your plugins dir:

wvdf96a 08-08-2004 10:10 PM

I do have the following plugins (for RealPlayer10) in /usr/lib/mozilla/plugins: -> /usr/local/RealPlayer/mozilla/*
nphelix.xpt -> /usr/local/RealPlayer/mozilla/nphelix.xpt*

And, Mozilla will invoke RealPlayer10 if I enter one of the supported files directly in the browser address bar.
But, it does not do that when the file is embedded within the JavaScript call...

Still stumped....


yackko 08-12-2004 10:51 AM

Playing Video in Mozilla
I'm having the same issue as well. I placed all the plugin files from the /usr/lib//RealPlayer/mozilla folder. I placed the .so file in the Mozilla brower Plugin folder, then place the .xpt file in the Mozilla browser Component folder. Still no luck. I think the issue might be a bug with Mozilla 1.7.2 not being able to call on the helper file. I don't know. I try everything and none of the solution seems to work.

I'm posting this as a reply to prevent duplicate post.

I'm using Fedora Core 2. No luck in finding a solution on the Mozilla or RealPlayer/Helix site. The plugin shows up okay when I go to Mozilla/Help/About Plugins. It shows up there and status as "Yes"

yackko 08-13-2004 10:33 AM

I overlayed the installation. I created a dynamic link again. It work until I rebooted.

Anybody no a fix to this problem?



wvdf96a 08-13-2004 11:28 AM

Some progress
Your last post inspired me to try something. I copied the .xpt
files (which are currently sitting in my /usr/lib/mozilla/plugins
folder to the /usr/lib/mozilla/components folder.

Then, I was able to get a video clip from USAToday (front page) to work
just fine. It brings up the RealPlayer window and plays the video. This
doesn't look like the RealPlayer10 that I have installed but it plays just
the same (if a bit jerky).

However, when I tried to play similiar JavaScript embedded clips from the Life page, they
don't work. I'm somewhat suspicious of USAToday's web server now
but will keep experimenting and try to learn more about Java. Thanks for your hints.


yackko 08-14-2004 09:38 AM

solution or work around. However you want to view it...
Glad to help.

I give up. My opinion on problems is if it can't be solved in seven days or if no one post a fix to the problem, then it's not worth the time and it's time to look at alternatives...I'm pretty sure it's a bug in either Mozilla or RealPlayer 10.

Well I forgot that I had FireFox installed on my Linux boxes. I open Firefox up and went to and was able to open up an embedded RealPlayer plugin within the browser It's was a great feeling. Then I went to USAToday, ESPN, and some other sites that required the RealPlayer plugin and it works. Just in case you're not fimiliar with Firefox, it's a browser owned and is the next generation browser from Mozilla. Don't get me wrong, I like mozilla a lot, but it doesn't work with some plugins I want it to use that are embedded. Firefox instead, once you create a dynamic link, it uses that, and run with it. Everyting is working fine on FireFox, but I'm still not having much luck with RealPlayer 10 with Mozilla. I would recommend crossing over to FireFox for now or permenantly. I've used FireFox on all my Windows boxes and they are working better then IE. Damn I sound like a spokesman/salesman for FireFox...Anyway, FireFox is a free browser, and it's a standalone browser. You don't have to install it, just download it, extract it, create a shortcut to the FireFox browser script, and you're ready to browse. You may have to re-install RealPlayer then after that, but try it first before you do.

Hope that helps wvdf96a[/B].


wvdf96a 08-14-2004 12:00 PM

On Trying Firefox...
Thanks. I'll try Firefox when I get some time but things
are working much better for me at the moment (still w/ Mozilla).

The iFilm link is a good one for testing this stuff.
I went there and had no problem playing any of the links
(which all seem to be embedded JavaScript) w/ my RealPlayer10.

For now, I'm in fairly good shape. Thanks for your help!


All times are GMT -5. The time now is 10:18 AM.