Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-04-2005, 04:53 PM   #1
LQ Newbie
Registered: Aug 2005
Location: Memphis, TN
Distribution: Mandriva 2006
Posts: 19

Rep: Reputation: 0
pkg-config version problems

Good afternoon everyone.
This problem has me stumpted (not that it's a very hard thing to do). I'm trying to use garnome 2.10 to update gnome and have been having a number of problems. This is the latest problem:

When running make paranoid-install, I get the following error when it tries to configure gnome-doc-utils-0.2.0.

./configure: line 5436: /usr/lib/pkgconfig: is a directory
*** Your version of pkg-config is too old. You need version 0.9.0 or newer.
*** See
configure: error: Library requirements (
libxml-2.0 >= 2.6.12
libxslt >= 1.1.8
) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
make[2]: *** [configure-/usr/local/garnome/garnome-work/gnome-doc-utils/main.d/gnome-doc-utils-0.2.0/configure] Error 1
make[2]: Leaving directory `/usr/local/garnome-2.10.2/desktop/gnome-doc-utils'
make[1]: *** [../../desktop/gnome-doc-utils/cookies/main.d/install] Error 2
make[1]: Leaving directory `/usr/local/garnome-2.10.2/desktop/bug-buddy'
make: *** [paranoid-install] Error 2

pkg-config --version returns 0.19
pkg-config --modversion libxml-2.0 returns 2.6.17
pkg-config --modversion libxslt returns 1.1.14


When I installed pkg-config 0.19, I ran ./configure --prefix=/usr
I imagine that the problem with libxml and libxslt has to do with pkg-config not being found by the configure script, so I'm not concerned with them.

I'm on Mandrake 10.2.

Thank you.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
*** pkg-config too old; version 0.14 or better required. sfaae Linux - Newbie 2 07-11-2009 03:23 PM
Problems with PKG-Config wmustudent99 Linux - Newbie 2 02-04-2005 04:34 AM
pkg-config supersucker Linux - Software 3 09-07-2004 09:45 AM
can't download pkg-config?...newer version needed... breezewax Linux - Software 1 09-06-2004 10:07 PM
I got problems with pkg-config and pango Boogieman Mandriva 1 09-11-2003 08:45 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:40 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration