-   Linux - Software (
-   -   pkg-config version problems (

Spooled 09-04-2005 04:53 PM

pkg-config version problems
Good afternoon everyone.
This problem has me stumpted (not that it's a very hard thing to do). I'm trying to use garnome 2.10 to update gnome and have been having a number of problems. This is the latest problem:

When running make paranoid-install, I get the following error when it tries to configure gnome-doc-utils-0.2.0.

./configure: line 5436: /usr/lib/pkgconfig: is a directory
*** Your version of pkg-config is too old. You need version 0.9.0 or newer.
*** See
configure: error: Library requirements (
libxml-2.0 >= 2.6.12
libxslt >= 1.1.8
) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
make[2]: *** [configure-/usr/local/garnome/garnome-work/gnome-doc-utils/main.d/gnome-doc-utils-0.2.0/configure] Error 1
make[2]: Leaving directory `/usr/local/garnome-2.10.2/desktop/gnome-doc-utils'
make[1]: *** [../../desktop/gnome-doc-utils/cookies/main.d/install] Error 2
make[1]: Leaving directory `/usr/local/garnome-2.10.2/desktop/bug-buddy'
make: *** [paranoid-install] Error 2

pkg-config --version returns 0.19
pkg-config --modversion libxml-2.0 returns 2.6.17
pkg-config --modversion libxslt returns 1.1.14


When I installed pkg-config 0.19, I ran ./configure --prefix=/usr
I imagine that the problem with libxml and libxslt has to do with pkg-config not being found by the configure script, so I'm not concerned with them.

I'm on Mandrake 10.2.

Thank you.

All times are GMT -5. The time now is 03:34 AM.