-   Linux - Software (
-   -   pkg-config problems (

RhysBJ 06-30-2006 05:43 AM

pkg-config problems
I'm trying to build Anjuta, but for that I need to first build gdl-1.0. I've installed gdl, but it's been installed into /usr/local/lib not /usr/lib. gdl-1.0.pc is in /usr/local/lib/pkg-config, but when I run pkg-config --libs gdl-1.0 I get the error: Package gdl-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gdl-1.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gdl-1.0' found

I'm guessing that I need to include /usr/local/lib/pkg-config in the pkg-config search path.

Is this correct? If so how do I do it? It not, what should I do to solve this?

bathory 06-30-2006 07:00 AM

You can either copy gdl-1.0.pc in /usr/lib/pkgconfig, or define PKG_CONFIG_PATH:

export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH

RhysBJ 06-30-2006 07:09 AM

Thank you :)

RhysBJ 06-30-2006 10:26 AM

I managed to install anjuta, but now it crashes on start up with the following error:
anjuta: error while loading shared libraries: cannot open shared object file: No such file or directory
This file is in /usr/local/lib/, and I have copied libanjuta-1.0.pc to /usr/lib/pkgconfig

bathory 06-30-2006 04:01 PM

You should put /usr/local/lib in /etc/ and then run:

You can also add the following line in /etc/profile:

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

RhysBJ 06-30-2006 05:26 PM

That fixed it, though /usr/local/lib was already in and I had already run ldconf after it had been added. This was a couple of days ago though...

bathory 06-30-2006 05:37 PM

You have to run ldconfig everytime you add new libraries if it's not done by the "make install", if you want to make them available, right away after the installation, to other programs.

All times are GMT -5. The time now is 01:50 PM.