-   Linux - Software (
-   -   pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6 (

ghrellin 12-20-2004 12:28 AM

pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6
I'm running Gentoo Linux, kernel version 2.6.9-gentoo-r6 with a few unstable packages (gaim, mplayer, not many) and the dependencies for gnome-python emerge perfectly. However, when I try to emerge gnome-python (2.6.1, unstable) I get the following:

checking for GTK+ - version >= 2.4.0...
*** 'pkg-config --modversion gtk+-2.0' returned 2.4.9, but GTK+ (2.4.13)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error: maybe you want the gtk-gnome-1-2 branch?

Although gnome-python 2.6.1 is unstable, I get the same error when I try to emerge the stable version. I'm going for unstable because rbscrobbler (rhythmbox audioscrobbler plugin) requires it, just to head off answers telling me to use the stable version.

uman 12-22-2004 01:21 PM

I had this same problem when trying to emerge gtkglarea. I think the problem in your case is two conflicting versions of GTK+
Did you ever install GTK+ yourself? (without portage, by doing ./configure && make && make install)
If so, uninstall it, then remerge GTK+ through portage.

ghrellin 12-22-2004 06:37 PM

This problem went away when I did

emerge -aDu world
a few days ago.
Unfortunately, I didn't write down which packages were updated. Anyway, it works.

All times are GMT -5. The time now is 09:23 AM.