LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   pkg-config (https://www.linuxquestions.org/questions/linux-software-2/pkg-config-227302/)

supersucker 09-06-2004 10:07 AM

pkg-config
 
hi,

i tried to install gtk, and ended up with the following error message after running ./configure:

*** Your version of pkg-config is too old. You need version 0.9.0 or newer.
configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

which is weird, because i have installed the newest version pkgconfig-0.15.0

any piece of advice would be appreciated, i dont know how to fix that error...thx

Andrew Benton 09-06-2004 12:34 PM

You've not given us much to go on. You could tell us what distro you're using. From the look of your error message the configure script has found an old version of pkg-config. Presumably it's installed in /usr and you installed the new version in /usr/local so bash is finding the old version first. You can usually choose where to install things by passing the option --prefix=/some/where to configure like so
./configure --prefix=/usr
To find out some of the other options available, try
./configure --help

supersucker 09-07-2004 08:52 AM

thanks for the help,

i will try that, oh and the distribution is suse linux 9.1...
is there any way i can completely erase the old version of pkg-config when i compiled the programm?
is simply erasing the old programm files and setting the path to the location of the new pkg-config sufficient?

Andrew Benton 09-07-2004 09:45 AM

You can re-arrange your $PATH how you want. To see what it's set to at the moment,
echo $PATH
To set it to something else, for example
export PATH=/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin
This allows you to set the order so that it looks in /usr/local/bin before /usr/bin. When you close the shell the value you set your $PATH to will be unset so it won't make any permanent change.

What I don't understand is why your error message says "Your version of pkg-config is too old. You need version 0.9.0 or newer." Doesn't SuSE 9.1 use pkg-config-0.15? Maybe the configure script didn't find pkg-config at all.
There isn't a simple way of uninstalling things that were installed from source. Some packages support make uninstall but you need to either have the original source to do it with or compile it again with the same configure options. Sometimes the only thing to do is to delete the files by hand.


All times are GMT -5. The time now is 07:17 PM.