LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-22-2010, 04:49 PM   #1
Touch
LQ Newbie
 
Registered: Oct 2009
Distribution: RHEL & Fedora
Posts: 25

Rep: Reputation: 0
php_oci8 install problems


Hello Everyone,

I am sorry if this is a repeat thread but i am really at a loss here. I have installed oci8 from the remi repo and can not get it to work. I have been trying all day but still end up with the same error in my apache error log when I start httpd.

Code:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/oci8.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/pdo_oci.so' - libclntsh.so.11.1: cannot open shared object file: No such file or directory in Unknown on line 0
I followed the install instructions on the remi site for this but it didn't work. I also tried building the oci extension and php from source but i still get the same error.

If anyone can suggest something more I can try or where I should look next that would be nice. In the mean time I am going to build a VM and try from a fresh install and see what happens.

Regards
 
Old 11-22-2010, 09:37 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
I built an oci8 rpm last year ... you'll need to ensure the php and oracle client versions match what it was compiled against.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
AcidRip Install - Glib Install Problems - Dependecy Issue? Crash90 Linux - Software 4 03-02-2008 06:52 PM
apt-get install dependency problems with hplip software and kde install for Agnula maybi7 Linux - Software 1 02-03-2007 06:16 PM
install suse 9.3 on a PIII system??? problems in the install screen : flickers! :( akshay_jp SUSE / openSUSE 3 09-12-2006 12:53 PM
Ethernet Adsl Modem Driver Problems And Install Problems... akhilnair Linux - Hardware 12 11-28-2004 09:19 AM
SuSE problems; Mouse doesn't work, Wine won't install, WM won't install... Konig Linux - Distributions 1 01-22-2004 12:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration