LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-05-2017, 07:30 PM   #1
omci
LQ Newbie
 
Registered: Jul 2017
Posts: 5

Rep: Reputation: Disabled
Unhappy Php7 ZTS Installation Error: Broken Packages


I am trying to install php7.0-zts to further install pthreads. I am supposed to go through the following commands (I am doing this in my home directory on a virtual machine ubuntu 14.04):
Code:
sudo apt-get install -y language-pack-en-base
LC_ALL=en_US.UTF-8 sudo add-apt-repository ppa:ondrej/php-zts

sudo apt-get update
sudo apt-get install php7.0-zts php7.0-zts-dev
Upon reaching
Code:
sudo apt-get install php7.0-zts php7.0-zts-dev
I get the following error:
Code:
robotics@playground:~$ sudo apt-get install php7.0-zts php7.0-zts-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php7.0-zts : Depends: libapache2-mod-php7.0-zts (>= 7.0.2-1+zts+deb.sury.org~trusty+1~) but it is not going to be installed or
                       php7.0-zts-cgi (>= 7.0.2-1+zts+deb.sury.org~trusty+1~) but it is not going to be installed or
                       php7.0-zts-fpm (>= 7.0.2-1+zts+deb.sury.org~trusty+1~) but it is not going to be installed
              Depends: php7.0-zts-common (>= 7.0.2-1+zts+deb.sury.org~trusty+1~) but it is not going to be installed
 php7.0-zts-dev : Depends: php7.0-zts-cli (>= 7.0.5-4+donate.sury.org~trusty+1) but it is not going to be installed
                  Depends: php7.0-zts-common (= 7.0.5-4+donate.sury.org~trusty+1) but it is not going to be installed
                  Recommends: dh-php but it is not installable
E: Unable to correct problems, you have held broken packages.
How should I solve these broken packages? Initially, I tried following another method to install php 5.8. However, it was error prone and didn't work ,then I came across the above mentioned commands. Any help will be greatly appreciated.

Last edited by omci; 07-05-2017 at 11:40 PM.
 
Old 07-06-2017, 02:34 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu, mint, suse
Posts: 1,591

Rep: Reputation: 145Reputation: 145
Have you removed the 5.8 packages before installing the 7.0? If not I would try that.
 
  


Reply

Tags
php, pthreads


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Php7 Installation with Php5 on Ubuntu mahi_nix Linux - Server 3 02-12-2016 01:28 AM
iRedMail Broken Packages Error DevAndy Linux - Software 2 01-06-2014 12:39 AM
Crunchbang 10; can't fix broken packages (error exit status 1) HappyTheCat Linux - Newbie 7 11-02-2012 07:26 PM
apt-get install error, E: Broken packages Slick666 Debian 1 07-13-2007 12:53 PM
php7 + apache2 installation problems Misha Ubuntu 4 05-23-2007 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration