-   Linux - Software (
-   -   php5 configure with different php.ini file (

dtra 01-19-2005 07:02 PM

php5 configure with different php.ini file
hi all

i'm trying to compile php5 to use a different php.ini file
in my configure line i have this, among a lot of other stuff

'--with-config-file=/etc/php5.ini' '--with-config-file-path=/etc'

but the php5.ini file is never created
i ran make, and make install afterwards but the file still did not appear
does the position of the two lines above in the configure options matter?
cos they are at the end

using redhat 9, apache 2

the whole config line if you need that

'./configure' 'i686-redhat-linux' '--prefix=/usr' '--exec-prefix=/usr'
'--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share'
'--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec'
'--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--prefix=/usr' '--with-config-file-path=/etc'
'--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect'
'--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization'
'--with-bz2' '--with-curl' '--with-dom=/usr' '--with-dom-xslt=/usr'
'--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr/local'
'--with-gd=/usr' '--enable-gd-native-ttf' '--with-ttf' '--with-gdbm'
'--with-gettext=shared' '--with-ncurses' '--with-gmp' '--with-iconv'
'--with-jpeg-dir=/usr' '--with-openssl' '--with-pear' '--with-png' '--with-pspell'
'--with-regex=system' '--with-xml' '--with-expat-dir=/usr'
'--with-zlib-dir=/usr/local' '--with-layout=GNU' '--enable-bcmath'
'--enable-debugger' '--enable-exif' '--enable-ftp=shared'
'--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets'
'--enable-sysvsem=shared' '--enable-sysvshm=shared' '--enable-discard-path'
'--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx'
'--without-oci8' '--with-imap=shared' '--with-imap-ssl'
'--with-kerberos=/usr/kerberos' '--with-ldap=shared' '--with-mysql=shared,/usr'
 '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared'
'--enable-ucd-snmp-hack' '--enable-memory-limit' '--enable-bcmath'
'--enable-shmop' '--enable-versioning' '--enable-calendar' '--enable-dbx'
'--enable-dio' '--enable-mcal' '--enable-mbstring' '--enable-mbstr-enc-trans'
 '--disable-experimental-zts' '--with-apxs2filter'
'--with-mysql-sock=/var/lib/mysql/' '--enable-simplexml'
'--with-config-file=/etc/php5.ini' '--with-mysqli=/usr/bin/mysql_config'


btmiller 01-19-2005 07:43 PM

You can copy the php.ini-dist (I think that's the correct name) from the source directory to the location you specified for it, and the edit it to suit your environment. IIRC PHP expects you to do this yourself so you make sure to look at the config file.

dtra 01-19-2005 08:04 PM

hi, thanks for your reply
i tried putting the file there
but the problem is, and i probably should have mentioned this earlier, we are trying to install and run side-by-side with php4
it doesn't seem to want to use /etc/php5.ini
just /etc/php.ini

All times are GMT -5. The time now is 04:51 AM.