LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-23-2003, 11:59 PM   #1
MaleMe
LQ Newbie
 
Registered: Jun 2002
Location: Texas
Distribution: RedHat
Posts: 7

Rep: Reputation: 0
Unhappy PHP4.3 configure error


I currently have RedHat Linux 7.2 running Apache 1.3.27 and MySQL 3.23.53. During installation of PHP 4.3.0 executed the following from the php directory:
./configure --with-mysql=/usr/local/mysql --with-config-file-path=/www/conf --with-apache=../httpd --enable-track-vars

the following warning resulted:
you will need bison if you want to regenerate the PHP parsers

configure stopped with this error:
checking lex output file root... ./configure: lex: command not
found
configure: error: cannot find output from lex; giving up

What is lex?
I have checked my paths and they all seem valid.
I have used this same process once before on RH Linux 7.2 with an older version of PHP4 and did not encounter this error.

Any help would be greatly appreciated.
 
Old 01-24-2003, 11:52 AM   #2
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
It means FLEX (fast lexical analyzer generator). just install the rpm of flex and you can compile php 4.3+
 
Old 01-25-2003, 08:19 PM   #3
MaleMe
LQ Newbie
 
Registered: Jun 2002
Location: Texas
Distribution: RedHat
Posts: 7

Original Poster
Rep: Reputation: 0
Installed flex-2.5.4a-26.rpm and the above error went away.
The next error encountered was during the Configuring Extensions part.
configure: error: Cannot find libz
I then installed the bison-1.35-4.rpm per php.net FAQs.... error remained the same.
Searched for libz and found it at /usr/lib.
Ran the previously mentioned configure script with "--with-libz-dir=/usr/lib" at the end.... same error.
I guess it's looking for a different libz, any suggestions at this point??

Thanks
 
Old 01-25-2003, 11:17 PM   #4
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
Well I've installed following rpm's (rpm -qa):
Quote:
filesystem-2.1.6-5
glibc-2.2.93-5
bzip2-libs-1.0.2-5
cracklib-2.7-18
e2fsprogs-1.27-9
gdbm-1.8.0-18
glib2-2.0.6-2
iputils-20020124-8
libacl-2.0.11-2
libgcc-3.2-7
mingetty-1.00-3
net-tools-1.60-7
perl-5.8.0-55
popt-1.7-1.06
slang-1.4.5-11
termcap-11.0.1-13
bash-2.05b-5
ncurses-5.2-28
diffutils-2.8.1-3
grep-2.5.1-4
openssl-0.9.6b-29
psmisc-20.2-6
redhat-release-8.0-8
ntp-4.1.1a-9
textutils-2.0.21-5
utempter-0.5.2-10
words-2-20
pam-0.75-40
sh-utils-2.0.12-3
modutils-2.4.18-2
initscripts-6.95-1
libuser-0.51.1-2
python-2.2.1-17
util-linux-2.11r-10
at-3.1.8-31
bind-utils-9.2.1-9
cpio-2.4.2-28
dev-3.3.1-2
findutils-4.1.7-7
ftp-0.17-15
gpm-1.19.3-23
grub-0.92-7
hesiod-3.0.2-21
ksymoops-2.4.5-1
less-358-28
libelf-0.8.2-2
libwvstreams-3.70-5
logrotate-3.6.5-2
lsof-4.63-2
mailx-8.1.1-26
make-3.79.1-14
man-1.5j-11
nscd-2.2.93-5
passwd-0.67-3
procmail-3.22-7
python-optik-1.3-2
redhat-logos-1.1.6-2
rmt-0.4b28-4
rootfiles-7.2-4
rpm-python-4.1-1.06
slocate-2.6-4
stunnel-3.22-4
syslinux-1.75-3
mkinitrd-3.4.28-1
tcp_wrappers-7.6-23
telnet-0.17-23
tmpwatch-2.8.4-3
unzip-5.50-5
usbutils-0.9-7
vixie-cron-3.0.1-69
zip-2.3-14
automake-1.6.3-1
byacc-1.9-22
cpp-3.2-7
flex-2.5.4a-26
glibc-devel-2.2.93-5
libstdc++-devel-3.2-7
m4-1.4.1-11
patch-2.5.4-14
rpm-build-4.1-1.06
ctags-5.2.3-4
diskcheck-1.3-2
comps-8.0-0.20020910
cyrus-sasl-2.1.10-1
hwdata-0.48-1
pine-4.44-14.80.0
xinetd-2.3.7-5
openssl-devel-0.9.6b-29
openssh-3.5p1-1
openssh-server-3.5p1-1
vim-common-6.1-18.8x.1
vim-minimal-6.1-18.8x.1
glibc-common-2.2.93-5
setup-2.5.20-1
basesystem-8.0-1
bdflush-1.5-21
chkconfig-1.3.6-3
db4-4.0.14-14
expat-1.95.4-1
glib-1.2.10-8
gmp-4.1-4
libattr-2.0.8-3
libcap-1.10-12
libstdc++-3.2-7
mktemp-1.5-16
pcre-3.9-5
perl-Filter-1.28-9
shadow-utils-20000902-12
newt-0.51.0-1
libtermcap-2.0.8-31
iproute-2.4.7-5
info-4.2-5
gawk-3.1.1-4
fileutils-4.1.9-11
procps-2.0.7-25
readline-4.3-3
sed-3.02-13
sysklogd-1.4.1-10
mount-2.11r-10
which-2.14-1
cracklib-dicts-2.7-18
authconfig-4.2.12-3
SysVinit-2.84-5
openldap-2.0.25-1
usermode-1.63-1
zlib-1.1.4-4
rhpl-0.51-1
acl-2.0.11-2
attr-2.0.8-3
bzip2-1.0.2-5
crontabs-1.10-4
file-3.37-8
finger-0.17-14
gnupg-1.0.7-6
groff-1.18-6
hdparm-5.2-1
kbd-1.06-26
kudzu-0.99.69-1
gzip-1.3.3-5
libtool-libs-1.4.2-12
lockdev-1.0.0-20
losetup-2.11r-10
lvm-1.0.3-9
MAKEDEV-3.3.1-2
man-pages-1.53-1
pinfo-0.6.4-7
pyOpenSSL-0.5.0.91-1
raidtools-1.00.2-3.3
rhnlib-1.0-1
dump-0.4b28-4
rpm-4.1-1.06
sendmail-8.12.5-7
star-1.5a04-1
sudo-1.6.6-1
tar-1.13.25-8
iptables-1.2.6a-2
quota-3.06-5
tcpdump-3.6.3-3
time-1.7-19
traceroute-1.4a12-6
up2date-3.0.7-1
hotplug-2002_04_01-13
anacron-2.3-23
whois-1.0.10-4
ncurses-devel-5.2-28
binutils-2.13.90.0.2-2
cdecl-2.5-25
dev86-0.16.3-4
glibc-kernheaders-2.4-7.20
gcc-3.2-7
gcc-c++-3.2-7
autoconf-2.53-8
patchutils-0.2.14-3
strace-4.4-8
nmap-3.00-1
cproto-4.6-13
elinks-0.3.2-1
sendmail-cf-8.12.5-7
gpg-pubkey-db42a60e-37ea5438
cyrus-sasl-md5-2.1.10-1
krb5-libs-1.2.5-7
wget-1.8.2-5
kernel-2.4.18-19.8.0
MySQL-shared-4.0.9-0
openssh-clients-3.5p1-1
vim-enhanced-6.1-18.8x.1
logwatch-4.3.1-1
The relevant part of it (what you should check for):
Quote:
gdbm-1.8.0-18
automake-1.6.3-1
byacc-1.9-22
cpp-3.2-7
flex-2.5.4a-26
glibc-devel-2.2.93-5
libstdc++-devel-3.2-7
patch-2.5.4-14
ctags-5.2.3-4
binutils-2.13.90.0.2-2
cdecl-2.5-25
dev86-0.16.3-4
glibc-kernheaders-2.4-7.20
gcc-3.2-7
gcc-c++-3.2-7
autoconf-2.53-8
patchutils-0.2.14-3
cproto-4.6-13
This list was taken from a RH 8.0 box ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help loading php4-gd with php4 already installed. (Debian) sdduuuude Linux - Software 3 10-24-2005 06:13 AM
How do I configure php4 & apachee 1.3? walterbyrd Debian 10 08-22-2004 08:34 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 04:52 PM
php4 make/install error BobNz Linux - Software 0 05-03-2004 01:02 AM
PHP4 & Apache Install Error yazan Programming 2 02-28-2002 04:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration