LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   php problem (https://www.linuxquestions.org/questions/linux-software-2/php-problem-500086/)

manomohan 11-09-2006 10:35 AM

php problem
 
i am using the fedora core 4. that have the 5.0. while i try to install moodle, that ask for php 5.2. I installed that with following commands,

./configure
make
make install

after i checked with the command "rpm -qa php", then it shows the older version..

How can i fix this.

mjmwired 11-09-2006 05:15 PM

You cannot "fix" this. The 'rpm' command will only show any RPM's installed. The method you used to install is known as "installation from source". When you install from source it will not show up in the RPM list. You must install a 5.2 RPM for that to work.

What I recommend is uninstall the PHP from Fedora:
# yum remove php
Then your 5.2 installation will be the only PHP installed.

Better way to check, run:
# php -v


All times are GMT -5. The time now is 12:27 AM.