LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-30-2005, 01:24 PM   #1
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Rep: Reputation: 30
php-nuke blank admin.php


I have setup php-nuke and am getting a blank page when I access admin.php. I have apache and php set up correctly because i can view php pages that reside on my server. I have searched this site and google but have not been able to find a solution i can use. Any suggestions or documentation on how to resolve this? Thanks
 
Old 04-30-2005, 07:14 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
You may need to add admin.php here;
###
### DirectoryIndex: Name of the file or files to use as a pre-written HTML
### directory index. Separate multiple entries with spaces.
###
<IfModule mod_dir.c>
DirectoryIndex index.html index.html.var index.php index.php3 main.php guestbook.php index.shtml index.cgi index.pl index.htm Default.htm default.htm
</IfModule>
 
Old 04-30-2005, 08:50 PM   #3
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
Still get a blank page when accessing admin.php. I unzipped phpnuke off the root of the web server. So I try to access the page by x.x.x.x/html/admin.php, just to give a little more info.

Below is the portion of my httpd.conf you referenced

#
# DirectoryIndex: Name of the file or files to use as a pre-written HTML
# directory index. Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
DirectoryIndex index.html admin.php
</IfModule>

Is this all I need? Could it be that for whatever reason the database didn't get populated? I verified the existance of the nuke database but not the table data (don't know how). Any other suggesions? If there is info i am leaving out that would be helpful please let me know and i will post it ASAP. Thanks
 
Old 04-30-2005, 09:42 PM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Is this how you set up the tables;
http://phpnuke.org/modules.php?name=...e-nukesql.html
You need to install everything before you go to admin.I have never installed phpnuke,i've installed phpBB2 guidebook openbook and some other stuff.I just create the database with mysql and then run the script that comes with them to create the tables.Do you have phpmyadmin installed?
also I would add index.php to that file,thats what most php programes look for .I had to add guestbook.php and main.php to mine for something I installed.
Here is the how to for phpmyadmin
http://phpnuke.org/modules.php?name=...nstall-db.html
This is from the install.txt for 7.6


Unzip the package into the directory you want to use on you web

server, if you're unsure where that is, ask you system administrator.



Now go to the directory where you uncompressed all files and edit the

file "config.php". Change all the fields until you are happy with the

changes and they fits the need of your web site. Give special attention

to the database configuration section. When you have finished to edit

config.php file change to the /sql/ directory and there is a file called

"nuke.sql" this file contains the commands to build the database structure,

tables and the default data.



If you're using a software like phpMyAdmin go to step 3.



1) Create a database called, for example, nuke:



mysqladmin create nuke



2) Now fill the databases with the tables in nuke.sql file:



mysql nuke < nuke.sql



3) In order to use the ultramode.txt news file please be sure to chmod 666.

This file is used to show news from your site in some old programs and

frontends and is reserved to future use in PHP-Nuke. For backend use

backend.php file instead.



4) That's it!... now you need to edit the file "config.php" to set the

database options. Please read carefully the instruction on that file!

After that, point your browser to:



http://phpnuke.org/admin.php



We use MySQL as the example and nuke.sql file is in MySQL format

because PHP-Nuke was made using this database server. You can find

many programs out there to convert the database schema from MySQL to

whatever else you want. But this is a task for you.





First Run

---------



Create your Super User following the on-screen instructions.

Now click on "Preferences" and change whatever you want to fit your

site info. All the options you need to change are in the Preferences

menu. If you need help just click con the help icon at the right-top

of the Administration Menu. This will open a new window with the help

you need for each section in the administration system.



SECURITY TIP: It's a good choice to put your config.php file outside the

Web Server path, then you can create a new config.php with the line:

<?php include("../config.php"); ?>


Last edited by comprookie2000; 04-30-2005 at 10:06 PM.
 
Old 05-01-2005, 02:08 PM   #5
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
Quote:
Is this how you set up the tables;
http://phpnuke.org/modules.php?name...ke-nukesql.html
no I just followed the steps 1-4

i am trying the webinstaller for phpnuke but end up with the same results when attempting to get to the php page-it is blank...

is it possible that php does not have mysql support? below is in my php.ini

; Load the MySQL module by default. Comment this out if you don't use MySQL.
extension=mysql.so

however i do have the database user and password stored in my php.ini


Any suggestions on other apps like phpnuke that I can try. I'm at my end with phpnuke.
 
Old 05-01-2005, 02:19 PM   #6
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Create a php file with <?php phpinfo(); ?> in it,put it in your document root and load it in your browser.
What does it say?

Last edited by comprookie2000; 05-01-2005 at 02:20 PM.
 
Old 05-01-2005, 02:34 PM   #7
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
I see the phpinfo page for php version 4.3.10. I also have other apps that use php such as squirlmail running correctly.
 
Old 05-01-2005, 05:52 PM   #8
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Did it show mysql in there?
 
Old 05-01-2005, 08:54 PM   #9
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
this is all it says about mysql, it is from the configure command section

'--with-mysql=shared,/usr'
 
Old 05-01-2005, 09:01 PM   #10
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Here is mine not sure if you can see it;
http://abbottdavid.no-ip.info/php.php
if not here is what it says near the bottom;
Code:
Directive	Local Value	Master Value
mime_magic.magicfile	/usr/share/misc/file/magic.mime	/usr/share/misc/file/magic.mime

mysql
MySQL Support	enabled
Active Persistent Links 	0
Active Links 	0
Client API version 	4.0.24
MYSQL_MODULE_TYPE 	external
MYSQL_SOCKET 	/var/run/mysqld/mysqld.sock
MYSQL_INCLUDE 	-I/usr/include/mysql
MYSQL_LIBS 	-L/usr/lib -lmysqlclient

Directive	Local Value	Master Value
mysql.allow_persistent	On	On
mysql.connect_timeout	60	60
mysql.default_host	no value	no value
mysql.default_password	no value	no value
mysql.default_port	no value	no value
mysql.default_socket	no value	no value
mysql.default_user	no value	no value
mysql.max_links	Unlimited	Unlimited
mysql.max_persistent	Unlimited	Unlimited
mysql.trace_mode	Off	Off

Last edited by comprookie2000; 05-01-2005 at 09:03 PM.
 
Old 05-02-2005, 07:01 AM   #11
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
You have

mysql
MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 4.0.24
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient

i do not. If i am following correctly i do not have mysql support enabled in php. I am assuming that i would have to recompile php to include mysql support. Is that correct? If so, since i installed php from the installation of slackware, what is the best way to achive this? Thanks
 
Old 05-02-2005, 02:03 PM   #12
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Looks like you will need to compile it with mysql support;
http://www.php.net/manual/en/install.unix.apache2.php
 
Old 05-02-2005, 10:06 PM   #13
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
recompiled and at least i can see the php pages associated with phpnuke, but i now have another problem. when i access the admin.php i receive the following message

There seems to be a problem with the MySQL server, sorry for the inconvenience.

We should be back shortly.


i have configured my config.php with the following:

$dbhost = "localhost";
$dbuname = "root";
$dbpass = "********"; password for root user
$dbname = "nuke";
$prefix = "nuke";
$user_prefix = "nuke";
$dbtype = "MySQL";
$sitekey = "SdFk*fa28367-dm56w69.3a2fDS+e9";
$gfx_chk = 0;
$subscription_url = "";
$admin_file = "admin";


getting very aggrevated...
 
Old 05-02-2005, 11:18 PM   #14
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Are you sure it is running,may need to restart it.Open up tail -f /var/log/messages and at the same time start it and look for errors.
Hang in there you close,something simple;
http://phpnuke.org/modules.php?name=...-php-file.html

Last edited by comprookie2000; 05-02-2005 at 11:43 PM.
 
Old 05-03-2005, 04:51 PM   #15
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
mysql is running and i see no entries in /var/log/messages when i start or stop mysql. I followed the instructions in the link you posted. Now i am getting the following when attempting to access admin.php

$AllowableHTML = array("b"=>1,^M
"i"=>1,^M
"a"=>2,^M
"em"=>1,^M
"br"=>1,^M
"strong"=>1,^M
"blockquote"=>1,^M
"tt"=>1,^M
"li"=>1,^M
"ol"=>1,^M
"ul"=>1);^M

and also the censor list which i won't post due to the censored words. This is all part of the config.php. Its like it won't process these php files but works on all others. I think I am going to start over unless you have some other idea. I really appreciate the time and effect you put into this thread. If you have any other ideas please let me know, i'm not looking forward to reinstalling.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PHP-Nuke? thorn168 Linux - Software 2 06-03-2005 10:57 AM
PHP-Nuke problems tictocdoc Linux - Networking 0 05-09-2004 08:19 PM
Php Nuke!!! FearPasion710 Linux - General 3 10-03-2003 03:43 PM
php-nuke with apache php mysql c0c0deuz Linux - Software 0 03-30-2003 06:23 AM
php nuke GT I.N.C Linux - General 2 08-08-2002 02:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration