Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-27-2003, 03:48 AM   #1
LQ Newbie
Registered: Jun 2003
Posts: 1

Rep: Reputation: 0
Red face Php not working afert instaled red hat 9

Hi !!!

I have a small problem i installed redhat 9 with all rpm. Everything was ok, since i realized my php is not working correctly.
I have web page with internet shop installed on php. But when i try to put some for example brake disc in a bracket, the bracket is empty. No error is send but i cannot put things in bracket..

Could anyone help me solving this problem.

Old 06-28-2003, 06:41 PM   #2
LQ Guru
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
if basic echo or phpinfo commands work than php is working there must be something with your script
Old 07-24-2003, 12:13 AM   #3
LQ Newbie
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
I've been trying

I have the same problem with Red Hat 9.0. I put echo phpinfo() in a script but i don't have the correct response. I don't know if apache recognized php by default or I need to add manually the module.
Old 07-24-2003, 07:29 PM   #4
Registered: Oct 2002
Location: Havertown PA
Distribution: Ubuntu/RHEL/Fedora
Posts: 253

Rep: Reputation: 31
have you run the command (from a command prompt)

php -v
which php

If those commands don't work, then you don't have php installed on your OS. If they do and you php scripts don't work with Apache, then yes, i believe you will see an option for some php functionality in the "details" view of the "web server" option in the package selection portion of the Redhat setup. You can get to that via the GUI by going to "system settings | add/remove applications". Look for "web server", click "details" and add all the php stuff. Should work like a charm.
Old 08-03-2003, 05:41 PM   #5
LQ Newbie
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
I execute the commands in the prompt and I have this answer:
[root@localhost root]# php -v
[root@localhost root]# which php
[root@localhost root]# rpm -aq|grep php

I execute the command rpm too. I think I have all the packages necessaries for php, but, I can't view correctly my php pages.
What I need to do more?
Please help me.
Old 09-19-2003, 06:53 AM   #6
Registered: Aug 2003
Distribution: Debian, Ubuntu
Posts: 188

Rep: Reputation: 30
Hi all,

I bet, it is the PHP-Version...
Current PHP-versions don't register GET or POST variables as globals. You can only acces them via $HTTP_GET_VARS["varname"] or $HTTP_POST_VARS["varname"].

I don't know, what was the first version with this property, but 4.2.2 definitively is.

If you are addicted to scripts using "old"-style, you can give
register_globals = on in /etc/php.ini.
But this is advised nowhere else, perhaps it causes security faults or what...

Clemens von Musil
Old 10-07-2003, 08:08 PM   #7
LQ Newbie
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
PHP not working after RedHat 9 installed

Hi ya all people out there,

I'm also having the same problem. I can't get my apache server to recognize the .php extensions.
Some help from any of you guys in here will be greatly appreciated.

I have selected the server package for my installation of RedHat 9. I know that my Apache webserver, PHP and mysql. Already pre-installed when I installed the RH9.

I have also tried configure the httpd.conf in the /etc/httpd/conf/
Adding the lines in below. Still with no luck.

LoadModule php4_module modules/
AddType application/x-httpd-php .php .php4 .phtml
AddType application/x-httpd-php-source .phps
I'll have already restarted the service everytime I edit some lines.

I notice by default install of RH9 my php.ini file is in /etc/ directory.
I'm assuming that's normal.
I'll also tried setting the register_globals = ON <--- So, with no luck. So I left it as default: register_global = OFF

At this point I'm running out of idea's what to do next. Can anyone please help me?

This is what I have in my RH9:
# php -v

# which php

# rpm -aq|grep php

Old 10-07-2003, 09:38 PM   #8
Registered: Jul 2003
Location: Orlando, FL
Distribution: mandrake 10
Posts: 62

Rep: Reputation: 15
check your error logs for apache and see if they give you any information about what is going wrong.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Making PHP files in Red Hat 9? NeoSephiroth Programming 1 10-17-2004 07:51 AM
install php on red hat 9 fledermaus Red Hat 16 09-30-2004 07:34 PM
add a lib to php in Red Hat 9 omelin Red Hat 2 08-10-2004 09:12 PM
PhP and Red Hat 8 studentforever Linux - Software 2 08-27-2003 02:12 AM
Red Hat 8 : PHP/MySQL/Apache jefx Linux - Newbie 10 05-28-2003 03:17 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration