Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 04-19-2003, 10:33 AM   #1
Registered: Feb 2002
Posts: 322

Rep: Reputation: 30
php? expat? apache?

I'm trying to install IMP from the horde project ( and I'm running into some really interesting issues. It won't run without xml support. It says to recompile php using --with-xml. Unfortunately, I'm not smart enough to compile much of anything yet.

I have every possible php xml module enabled and installed, and they seem to be working, but IMP still says I need xml support.

This is what phpinfo() reports as my configure command:
'./configure' '--prefix=/usr' '--enable-shared' '--disable-static' '--disable-debug' '--disable-rpath' '--enable-pic' '--enable-inline-optimization' '--with-config-file-path=/etc' '--enable-magic-quotes' '--enable-debugger' '--enable-track-vars' '--with-exec-dir=/usr/bin' '--with-versioning' '--with-mod_charset' '--with-expat-dir=/usr' '--with-regex=php' '--enable-force-cgi-redirect' '--enable-track-vars' '--enable-trans-sid' '--enable-safe-mode' '--with-ctype' '--with-ttf' '--with-freetype-dir=/usr' '--with-zlib' '--enable-sysvsem' '--enable-sysvshm' '--enable-yp' '--enable-ftp' '--with-gettext' '--without-aspell' '--without-kerberos'

The '--with-xml' option isn't there. expat for apache is installed, but apparently php isn't seeing it. phpinfo() doesn't show expat as installed. Since there are no configuration options in php.ini I am unsure of what to do next.

I would consider recompiling php, but I'm not sure I know what I'm doing. This server is also a production box, so I'm a little weary of doing much in terms of compiling. Is there anything else I can do here?

I've spent 2 weeks on this, and am going nowhere. I am lost. Any suggestions?
Old 04-19-2003, 10:53 AM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Have you restarted apache?
Old 04-20-2003, 01:36 PM   #3
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
Yes, I have restarted apache a number of times. I've done everything I can think of.

Old 04-20-2003, 01:38 PM   #4
Senior Member
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
looks like you need to recompile --with-xml, sorry. You may be able to find a php rpm with xml enabled...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
php apache or php cgi - php learner rblampain Linux - Security 3 12-17-2004 11:10 PM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 04:57 PM
fontconfig expat xml parse PROBLEMS!! OrganicOrange84 Linux - Software 0 08-18-2004 12:35 PM
reinstalled apache, php, still no php support SuSE 8.2 hindenbergbaby Linux - Software 1 10-14-2003 01:42 PM
expat!!! hhegab Linux - Software 6 07-20-2003 08:46 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration