LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2016, 12:48 PM   #1
vwtech
Member
 
Registered: Dec 2007
Distribution: Fedora, Oracle Linux & Centos
Posts: 197

Rep: Reputation: 26
PHP 5.6 with opcache


I complied php 5.6.25 and my info pages works but doesn't display "Zend OPcache" options as it did with 5.5.X.
Is "Zend OPcache" just not an option anymore in 5.6.X ?

Last edited by vwtech; 08-29-2016 at 12:59 PM.
 
Old 08-30-2016, 12:40 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,891

Rep: Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883Reputation: 1883
Quote:
Originally Posted by vwtech View Post
I complied php 5.6.25 and my info pages works but doesn't display "Zend OPcache" options as it did with 5.5.X.
Is "Zend OPcache" just not an option anymore in 5.6.X ?
First of all, I guess you have used "'--enable-opcache" in the ./configure script before compiling php, in order to add opcache support in php.

Then you should use the following in php.ini:
Code:
opcache.enable=1
zend_extension=/path/to/opcache.so
Regards
 
Old 08-30-2016, 09:31 AM   #3
vwtech
Member
 
Registered: Dec 2007
Distribution: Fedora, Oracle Linux & Centos
Posts: 197

Original Poster
Rep: Reputation: 26
I had the legacy directory instead of the current one in the "zend_extension=" directive thats in php.ini . Overlooked it because the new directory is very similar to the old one.
Now it works with no problems (Thanks all).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to install and configure SuiteCRM with OPcache on an Ubuntu 14.04 VPS LXer Syndicated Linux News 0 02-18-2015 02:20 AM
LXer: How To Build PHP 5.6 (PHP-FPM & FastCGI) with Zend OPcache And APCu For ISPConfig 3 On Debian LXer Syndicated Linux News 0 08-29-2014 01:30 PM
LXer: How To Build PHP 5.6-beta3 (PHP-FPM & FastCGI) With ionCube Loader, Zend OPcache And APCu For LXer Syndicated Linux News 0 05-30-2014 08:50 AM
PHP-5.5.x with Zend OPCache enabled causing segfault error 14 in libc-2.17.so Jeronimo Barros Slackware 7 11-24-2013 08:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration