LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-17-2004, 01:16 AM   #1
linux-addict
LQ Newbie
 
Registered: Apr 2003
Distribution: Red Hat 9.0
Posts: 23

Rep: Reputation: 15
PHP 4.3.4 + Apache 2.0.48 won't install


I have installed apache with the following paramenters:

./configure --enable-ssl --with-ssl=/usr/local/ssl/ --enable-so --enable-modules=all

That installed fine and everything functions properly, including https. Then I attempted to install php, but keep getting errors on "make install". It compiles fine, but won't make the module for apache, even though I point it at apxs. I compile php with the following parameters:

./configure --disable-all --disable-cli \
--with-mysql=/usr/local/mysql/ \
--with-openssl=/usr/local/ssl \
--with-pdflib /usr/local/lib \
--with-zlib-dir=/usr/lib \
--with-jpeg-dir=/usr/lib \
--with-png-dir=/usr/lib \
--with-ttf=/usr/lib \
--with-freetype-dir=/usr/lib \
--enable-versioning \
--enable-track-vars=yes \
--enable-url-includes \
--enable-sysvshm=yes \
--enable-sysvsem=yes \
--enable-ftp \
--with-config-file-path=/etc \
--with-gd \
--with-apxs2=/usr/local/apache2/bin/apxs

I have not installed any other packages associated these, and am running off of a RH9 system. The error I get when trying to install the compiled PHP files is:

Quote:
make install
Installing PHP SAPI module: apache2handler
/usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp4.la /usr/local/apache2/modules
/usr/local/apache2/build/libtool --mode=install cp libphp4.la /usr/local/apache2/modules/
cp .libs/libphp4.lai /usr/local/apache2/modules/libphp4.la
cp .libs/libphp4.a /usr/local/apache2/modules/libphp4.a
ranlib /usr/local/apache2/modules/libphp4.a
chmod 644 /usr/local/apache2/modules/libphp4.a
libtool: install: warning: remember to run `libtool --finish /storage/php-4.3.4/libs'
Warning! dlname not found in /usr/local/apache2/modules/libphp4.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /usr/local/apache2/modules/libphp4.so
chmod: failed to get attributes of `/usr/local/apache2/modules/libphp4.so': No such file or directory
apxs:Error: Command failed with rc=65536
.
make: *** [install-sapi] Error 1
Any idea how can I make this work?

Last edited by linux-addict; 01-17-2004 at 02:39 AM.
 
Old 01-17-2004, 09:47 PM   #2
linux-addict
LQ Newbie
 
Registered: Apr 2003
Distribution: Red Hat 9.0
Posts: 23

Original Poster
Rep: Reputation: 15
bump^

Any suggestions? This is a known problem, I could not find a solution though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache, PHP, MySQL Install SpiderIRE Linux - Software 3 10-03-2005 05:50 AM
install php --with-apache tunedLow Linux - Software 1 07-13-2004 09:30 AM
how do i install apache php and mysql ashokn Linux - Software 2 04-30-2004 07:20 AM
Apache 2.0 + PHP 4.3.0 install recommendations tarballed Linux - General 8 02-13-2003 12:54 PM
new apache-php install j-ray Linux - Software 1 04-01-2002 08:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration