LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-10-2009, 07:19 PM   #1
Adso
LQ Newbie
 
Registered: Jan 2009
Posts: 7

Rep: Reputation: 0
Exclamation Phoenix 1.5


I use xubuntu. I had downloaded Phoenix 1.5 and transformed to .deb with alien. Then I installed, but when I tried to execute it (with the command "phoenix" in the console) it saids:

phoenix: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

What thats it means? I wanna execute it, what should I do?

Thanks a lot!
 
Old 02-11-2009, 12:21 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Arch + Xfce
Posts: 6,852

Rep: Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037Reputation: 2037
Have you done what the error message suggested and made sure the libstdc++-libc6 library is installed?.

BTW, what's Phoenix 1.5? The only Phoenix I know of was the original (pre 1.0) name of the browser we now know of as Firefox.
 
Old 02-11-2009, 12:27 PM   #3
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
First try :
sudo apt-get install libstdc++6

If that doesn't work then can you post a link to where you downloaded you file? It was an rpm before right?
I think I can help if you give me this info.

Last edited by Dankles; 02-11-2009 at 12:30 PM.
 
Old 02-11-2009, 08:08 PM   #4
Adso
LQ Newbie
 
Registered: Jan 2009
Posts: 7

Original Poster
Rep: Reputation: 0
Exclamation

I installed the library but it still doesn't work.
The same message.
Yes it was transformed with the alien. The phoenix is a program to programming in BASIC in/for Linux.
The link is:

http://www.janus-software.com/phoenix_download.html


I would like to make it work.
Thank you very much
 
Old 02-11-2009, 08:43 PM   #5
Dankles
Member
 
Registered: May 2004
Location: /dev/null
Distribution: Slackware
Posts: 245

Rep: Reputation: 31
Hmmm.... I downloaded the file and was able to reproduce the error on my ubuntu box. It looks like both a problem with libstdc++6 and libpng. I tried creating sym-links to the libs it needs, but it looks like that wasn't enough.
I'd patch the package for you but it doesn't seem to be open source.
Sorry I can't help more. maybe you should stick with a redhat OS or run it under wine (though I don't recomend it)
 
  


Reply

Tags
execute, linux, phoenix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello from Phoenix blbaszis LinuxQuestions.org Member Intro 1 07-01-2008 01:03 PM
phoenix basic squimmy Linux - Software 3 05-28-2006 12:40 AM
about phoenix... LI-6Y LUCY Linux - Software 8 08-23-2003 12:49 PM
phoenix mailto nouse66 Linux - Software 2 02-14-2003 03:59 AM
Phoenix Browser BittaBrotha Linux - Software 5 11-04-2002 09:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration