-   Linux - Software (
-   -   Phantom Entry when scanning with mdadm.conf (

jdavidow 10-15-2007 06:38 PM

Phantom Entry when scanning with mdadm.conf
My system is down right now, so it's difficult to get exact file info (I have to type everything on a laptop).

I was running RAID5 on my system to create two md's (/dev/md0 and /dev/md1). 5 drives were divided up into two partitions each. I had 4 data drives + 1 parity.

When I run
mdadm --examine --brief --scan --config=partitions

I get the two entries in /etc/mdadm/mdadm.conf PLUS a third entry from somewhere else. The extra entry appears to be an OLD entry that must be embedded on the disks somewhere. I can't figure out how to get rid of it.

So this may have led to a failure- upon rebooting today the /dev/md0 array appears to have accessed the wrong entry and started to rebuild itself with the three drives (2+1) rather than the correct one (4+1).

Is there any way to try and recover that array?

jdavidow 10-16-2007 12:29 AM

Follow up info
If I run

mdadm -Ebsc partitions
I get the following output

ARRAY /dev/md0 level=raid5 num-devices=3 UUID=WW:XX:YY:ZZ spares=1
ARRAY /dev/md0 level=raid5 num-devices=5 UUID=WW:XX:YY:ZZ
ARRAY /dev/md1 level=raid5 num-devices=5 UUID=WW:XX:YY:ZZ

(All entries have different UUIDs)

The /etc/mdadm/mdadm.conf file only contains the last two entries, so I assume that the first is my old config that was not properly deleted when I revamped my system earlier this year.

I want to remove the first entry. Is there anyway to do this? If I use the examples I have seen, they only specify the device with /dev/md0, not the UUID.

How can I find out WHERE the entry (superblock) exists, and how to zero out just that one?

At one point today, when I rebooted, the system used that first entry and automatically started to rebuild the OLD array. I stopped the array as fast as I could, and it appears that things are OK. But I am scared to reboot into an automatic state!

All times are GMT -5. The time now is 01:28 AM.