Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 06-27-2015, 09:34 PM   #1
LQ Newbie
Registered: May 2015
Posts: 10

Rep: Reputation: Disabled
permissions problem with backup drive

I'm using a Linuxmint 17 xfce 64 b os, 3.13.0-24.
I'm attempting to backup my HOME folder using a usb backup drive.
I've been able to have the system recognize the backup drive, already formatted a partition using Gparted, selected the Home folder and certain files therein, copy or send to the appointed device, and then receive the following error message:
"The folder 'downloads' cannot be copied because you do not have permissions to create it in the destination".
Interestingly, if I access the backup drive, properties, permissions, it shows 'Root' as owner.
IF I were to plug in a usb stick, I can copy the files without any error messages, but not with the new backup usb drive. (The new drive is a SSD drive which I've formatted a partition to ext4).
I was not logged in as root at the time either which would probably have to be done from the command line.
Any help would be appreciated.
Old 06-28-2015, 11:05 PM   #2
LQ Guru
Registered: Apr 2008
Distribution: PCLinux, Slackware, Ubuntu
Posts: 9,980

Rep: Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329Reputation: 2329
Default behavior is to have root as the owner of partitions on external devices. Copy as root using sudo to preface the command or change the ownership of the directory mount point to your user. You seem to understand that so I'm not really clear on what the problem is?
1 members found this post helpful.
Old 06-29-2015, 07:38 AM   #3
LQ Guru
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Distribution: Mainly Devuan with some Tiny Core, Fatdog, Haiku, & BSD thrown in.
Posts: 5,014

Rep: Reputation: Disabled
Mounting the drive on a mount point owned by your user, (if I remember rightly), will allow your user to use it.
1 members found this post helpful.
Old 06-29-2015, 11:36 PM   #4
LQ Newbie
Registered: May 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks to both 'Fatmac'& 'Yancek'for your responses.
You confirmed my assumption about root being the default owner.
I will change the ownership to root using the terminal. I still haven't mastered that, but use every occasion to manually input commands to better understand how the linux file system functions.
I'll also utilize the web connections recommended.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mixed permissions on backup drive Col._Panic Linux - Security 1 08-26-2006 02:08 PM
backup recovery file permissions problem SlipAway172 Ubuntu 1 06-17-2005 11:10 AM
Shared drive permissions problem gchandler Red Hat 3 05-06-2004 04:00 AM
Permissions Problem with FAT32 Drive lawrencegoodman Linux - Newbie 4 11-13-2003 12:23 PM
fat drive permissions problem llimllib Linux - General 2 07-18-2003 07:51 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration