-   Linux - Software (
-   -   "Permission denied" when Openbox tries to execute in ~/.config/openbox (

alarazr 10-04-2012 11:53 AM

"Permission denied" when Openbox tries to execute in ~/.config/openbox
Hey guys. When I startx into Openbox from console, I'm left with just a black screen.

My custom menu, themes and everything still work, but none of my custom commands were loading. When I exited Openbox, I noticed "permission denied" when it had tried to execute in my home directory.

It's been like this since I removed GDM and installed Xfce4, then removed Xfce4 again after a couple of days.

Any help would be greatly appreciated.

alarazr 10-04-2012 01:51 PM

Bumping with additional information. I think it might be my .xinitrc in ~/


exec openbox

TobiSGD 10-04-2012 02:12 PM

Since this seems to be a permission problem let us have a look at that autostart-sript's permissions:

ls -l /home/alarazr/.config/openbox/

alarazr 10-04-2012 03:44 PM

I've fixed it man =) My .xinitrc needed to be openbox-session, not openbox.

TobiSGD 10-04-2012 03:50 PM

Thanks for posting back your solution. Please mark this thread as solved using the thread tools at the top of the thread.

All times are GMT -5. The time now is 02:07 PM.