-   Linux - Software (
-   -   Perl LWP::Protocol::https install failed via cpanm (

dhrumantgoradia 04-02-2013 10:17 PM

Perl LWP::Protocol::https install failed via cpanm
Trying to install LWP::Protocol::https using cpanm but it fails. Here is the build.log:


cpanm (App::cpanminus) 1.6103 on perl 5.010001 built for x86_64-linux-thread-multi
Work directory is /root/.cpanm/work/1364929453.16247
You have make /usr/bin/make
You have LWP 6.05
You have /bin/tar: tar (GNU tar) 1.23
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by John Gilmore and Jay Fenlason.
You have /usr/bin/unzip
Searching LWP::Protocol::https on cpanmetadb ...
--> Working on LWP::Protocol::https
-> OK
Unpacking LWP-Protocol-https-6.03.tar.gz
Entering LWP-Protocol-https-6.03
Checking configure dependencies from META.yml
Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.55_02)
Configuring LWP-Protocol-https-6.03
Running Makefile.PL
Checking if your kit is complete...
Looks good
Writing Makefile for LWP::Protocol::https
-> OK
Finding PREREQ from Makefile ...
Checking if you have Mozilla::CA 20110101 ... Yes (20130114)
Checking if you have IO::Socket::SSL 1.54 ... Yes (1.84)
Checking if you have LWP::UserAgent 6.04 ... Yes (6.05)
Checking if you have Net::HTTPS 6 ... Yes (6.04)
Building and testing LWP-Protocol-https-6.03
cp lib/LWP/Protocol/ blib/lib/LWP/Protocol/
Manifying blib/man3/LWP::Protocol::https.3pm
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t

#  Failed test at t/apache.t line 14.

#  Failed test at t/apache.t line 15.
#                  'Can't connect to (Network is unreachable)
# LWP::Protocol::https::Socket: connect: Network is unreachable at /usr/local/share/perl5/LWP/Protocol/ line 51.
# '
#    doesn't match '(?-xism:Apache Software Foundation)'
# Looks like you failed 2 tests of 2.
t/apache.t ..
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/2 subtests

Test Summary Report
t/apache.t (Wstat: 512 Tests: 2 Failed: 2)
  Failed tests:  1-2
  Non-zero exit status: 2
Files=1, Tests=2,  1 wallclock secs ( 0.02 usr  0.01 sys +  0.14 cusr  0.01 csys =  0.18 CPU)
Result: FAIL
Failed 1/1 test programs. 2/2 subtests failed.
make: *** [test_dynamic] Error 2
-> FAIL Installing LWP::Protocol::https failed. See /root/.cpanm/build.log for details.

The networking is fine as I've been downloading and installing packages via yum.
What am I missing here?

j-ray 04-03-2013 02:42 AM

have you tried
from the command line?

dhrumantgoradia 04-03-2013 02:44 PM


Originally Posted by j-ray (Post 4924060)
have you tried
from the command line?

Here's the result of "wget"


--2013-04-03 04:43:19--
Resolving,, 2001:610:1:80bc:192:87:106:229
Connecting to||:443... connected.
HTTP request sent, awaiting response... 400 Bad Request
2013-04-03 04:43:20 ERROR 400: Bad Request.

and cURL:

# curl
<title>400 Bad Request</title>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
 Instead use the HTTPS scheme to access this URL, please.<br />
<address>Apache/2.4.4 (Unix) OpenSSL/1.0.0g Server at Port 443</address>

dhrumantgoradia 04-04-2013 12:04 AM

[Solved] Perl LWP::Protocol::https install failed via cpanm
Going to on a browser also causes bad request so I looked at t/apache.t and saw it skips the test when there is no network connection so I just stoped the network and installed from the cpan shell instead of cpanm.

Installed successfully.

All times are GMT -5. The time now is 03:07 AM.