LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-23-2005, 02:31 AM   #1
kartheekpn
Member
 
Registered: Mar 2005
Location: bangalore
Posts: 100

Rep: Reputation: 15
perl-DBD-MySQL installation problem


Hello Everybody,

I have been using fc3 with MySQl-3.23 for a long time now. I now want to update to MySQL-4.1.14-0. I did the following,

1] I Removed all MySQl components, by unmarking the whole of mysql database options in Application-->System Settings-->Add Remove Applications

2] Then I installed the following rpm's:
MySQL-client-4.1.14-0.i386.rpm
MySQL-devel-4.1.14-0.i386.rpm
MySQL-server-4.1.14-0.i386.rpm

3]Next, I moved on to Install perl-DBD-MySQL, I tried the following versions:
perl-DBD-MySQL-3.0002-1.i386.rpm
rpm -i perl-DBD-MySQL-2.9007-1.i386.rpm

But, only to find a lot of dependency issues.....
I have been struggling with this for the past 48hrs....
How, am i suppose to proceed now, AnyBody Please guide me....
Any input regardsing the matter is a welcome.

Regards
KartheeK
 
Old 09-23-2005, 03:30 AM   #2
kartheekpn
Member
 
Registered: Mar 2005
Location: bangalore
Posts: 100

Original Poster
Rep: Reputation: 15
Hello All,

Now, I did the following...

[root@otrsbackup ~]# yum install perl-DBD-MySQL
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 977/977
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for perl-DBD-MySQL to pack into transaction set.
perl-DBD-MySQL-2.9003-5.i 100% |=========================| 5.3 kB 00:00
---> Package perl-DBD-MySQL.i386 0:2.9003-5 set to be installed
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.10 for package: perl-DBD-MySQL
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for mysql to pack into transaction set.
mysql-3.23.58-16.FC3.1.i3 100% |=========================| 36 kB 00:01
---> Package mysql.i386 0:3.23.58-16.FC3.1 set to be installed
--> Running transaction check
--> Processing Conflict: mysql conflicts MySQL
Traceback (most recent call last):
File "/usr/bin/yum", line 8, in ?
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 104, in main
(result, resultmsgs) = base.buildTransaction()
File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 174, in buildTransaction
(rescode, restring) = self.resolveDeps()
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 190, in resolveDeps
(checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
File "/usr/lib/python2.3/site-packages/yum/depsolve.py", line 494, in _processConflict
(confname, confarch, confepoch, confver, confrel) = conftuple[0] # take the first one, probably the only one
IndexError: list index out of range

What do i do now, even the great "yum" is failing.....
Plz Help......
Regards
KartheeK
 
Old 09-23-2005, 03:44 AM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
What are the dependency issues you had? Post exact errors.
 
Old 09-23-2005, 04:01 AM   #4
kartheekpn
Member
 
Registered: Mar 2005
Location: bangalore
Posts: 100

Original Poster
Rep: Reputation: 15
Ok, see this...

hey thanks for the response, look at this..

1]rpm -i perl-DBD-MySQL-2.9003-5.i386.rpm
error: Failed dependencies:
libmysqlclient.so.10 is needed by perl-DBD-MySQL-2.9003-5.i386

2]rpm -i perl-DBD-MySQL-2.9007-1.i386.rpm
error: Failed dependencies:
libcrypto.so.5 is needed by perl-DBD-MySQL-2.9007-1.i386
libmysqlclient.so.14 is needed by perl-DBD-MySQL-2.9007-1.i386
libssl.so.5 is needed by perl-DBD-MySQL-2.9007-1.i386
perl(:MODULE_COMPAT_5.8.6) is needed by perl-DBD-MySQL-2.9007-1.i386

I dont understand...

Regards
kartheeK
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Bugzilla - MySQL - perl - DBD::mysql install problem Runningonair Linux - Software 8 10-12-2007 01:42 AM
Error compiling perl-DBD-MySQL after upgrading to MySQL 4.1 pitaro920 Linux - Software 1 01-16-2006 05:28 PM
Error with Perl DBD::mysql ginda Programming 3 03-04-2005 07:20 PM
DBD-MySql-2.9004 Installation problem on Linux RedHat 9 luth Linux - Software 4 11-30-2004 05:56 AM
Can't install DBD::mysql or DBD::Pg DogTags Mandriva 2 01-21-2004 08:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration