LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-20-2017, 02:32 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
pcmanfm-how to get a terminal to open up in the dir off open in terminal


ok.

in Thunar it works if I select open in terminal but that is now my main File Manager,

pcmanfm is only opening the terminal but at /home/user not in the directory that I am selecting the open in terminal on.

How do I fix that. I have not an idea already

in the prefs under terminal I have this
Code:
terminator -e %s
what more do need to do to get pcmanfm to open in terminal in the directory I select it on?
 
Old 02-20-2017, 02:43 PM   #2
patrick295767
Member
 
Registered: Feb 2006
Distribution: FreeBSD, Linux, Slackware, LFS, Gparted
Posts: 660

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by BW-userx View Post
ok.

in Thunar it works if I select open in terminal but that is now my main File Manager,

pcmanfm is only opening the terminal but at /home/user not in the directory that I am selecting the open in terminal on.

How do I fix that. I have not an idea already

in the prefs under terminal I have this
Code:
terminator -e %s
what more do need to do to get pcmanfm to open in terminal in the directory I select it on?
it works here on my debian.
Code:
 dpkg -l | grep pcmanfm
ii  pcmanfm                       1.2.5-2                              i386         extremely fast and lightweight file manager
maybe try to compile it from source if you have issues, or get >1.2.5
 
Old 02-20-2017, 02:52 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by patrick295767 View Post
it works here on my debian.
Code:
 dpkg -l | grep pcmanfm
ii  pcmanfm                       1.2.5-2                              i386         extremely fast and lightweight file manager
maybe try to compile it from source if you have issues, or get >1.2.5
mine is ver. 1.2.5
 
Old 02-20-2017, 04:55 PM   #4
patrick295767
Member
 
Registered: Feb 2006
Distribution: FreeBSD, Linux, Slackware, LFS, Gparted
Posts: 660

Rep: Reputation: 137Reputation: 137
Quote:
Originally Posted by BW-userx View Post
mine is ver. 1.2.5
Looks the same, or likely.
I use openbox and fluxbox. Maybe this is the difference.

why does your sys when you do:
Code:
cd /tmp/ ; pcmanfm
 
Old 02-20-2017, 05:02 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by patrick295767 View Post
Looks the same, or likely.
I use openbox and fluxbox. Maybe this is the difference.
i'm in fluxbox I have not logged in to xfce4 which is my other likes to see if it is doing it in there but I am not currently using it in xfce4 so I didn't think of that until just now.
Quote:
Originally Posted by patrick295767 View Post
why does your sys when you do:
Code:
cd /tmp/ ; pcmanfm
I think you typo'ed and forgot a word in between sys and when maybe it should read

What does your sys do when you do?

it just opens up to /tmp

no warnings of anykind

I'M sudo nopasswd if it was suppose to ask for one.
 
Old 02-20-2017, 05:23 PM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
Code:
terminator -e %s
what more do need to do to get pcmanfm to open in terminal in the directory I select it on?
Try
Code:
terminator -e %u
 
1 members found this post helpful.
Old 02-20-2017, 05:28 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by Habitual View Post
Try
Code:
terminator -e %u
-- I tried that didn't work

so I just changed it to a terminal to see what that would do to one I do not prefer using and it works just fine either way

%s or %u

F'in bs

bs is for brisket and soup
 
Old 02-20-2017, 05:29 PM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Solved
it was the terminal brand terminator and nothing else but that...
 
Old 02-20-2017, 05:31 PM   #9
stanvan
Member
 
Registered: May 2007
Posts: 123

Rep: Reputation: 50
Quote:
Originally Posted by BW-userx View Post
ok.

in Thunar it works if I select open in terminal but that is now my main File Manager,

pcmanfm is only opening the terminal but at /home/user not in the directory that I am selecting the open in terminal on.

How do I fix that. I have not an idea already

in the prefs under terminal I have this
Code:
terminator -e %s
what more do need to do to get pcmanfm to open in terminal in the directory I select it on?
I'm using pcmanfm 1.2.4 -- in my Prefs>Advanced>Programs>Terminal emulator: I have x-terminal-emulator %s and right-clicking a folder give the option to Open (in pcmanfm) or the 4th down the list is Open in Terminal, which works as expected. This is in Linux Lite with XFCE.

Testing further, folders on the desktop behave differently. Right-clicking them gives Open Terminal Here further down the options, but it only opens in the ~/Desktop$ and not in the folder I wanted. It seems for it to work as I said above, I have to actually be in a pcmanfm window. From there, I can select Desktop in the Places on the left, then I get the right-click options on the folders on the right.
 
Old 02-20-2017, 05:33 PM   #10
stanvan
Member
 
Registered: May 2007
Posts: 123

Rep: Reputation: 50
Man, I type slow!
 
Old 02-20-2017, 05:39 PM   #11
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by stanvan View Post
I'm using pcmanfm 1.2.4 -- in my Prefs>Advanced>Programs>Terminal emulator: I have x-terminal-emulator %s and right-clicking a folder give the option to Open (in pcmanfm) or the 4th down the list is Open in Terminal, which works as expected. This is in Linux Lite with XFCE.

Testing further, folders on the desktop behave differently. Right-clicking them gives Open Terminal Here further down the options, but it only opens in the ~/Desktop$ and not in the folder I wanted. It seems for it to work as I said above, I have to actually be in a pcmanfm window. From there, I can select Desktop in the Places on the left, then I get the right-click options on the folders on the right.
well I do have terminator as a default terminal soooooo maybe that line might work so I can go back to using the one I prefer to use.
Quote:
Prefs>Advanced>Programs>Terminal emulator: I have x-terminal-emulator %s

failed to execute child process "x-terminal-emulator" (no such file or directory)
I think that x-terminal-emulator thing is a norm for calling default no name terminal likewise when one sees how it is setup to start default web browser without using the browsers name.

exo-open --launch WebBrowser

so maybe a little digging in to this because it is fluxbox so its more stripped down xinit or startup may need to have something added to tell fluxbox what it needs to know first.
 
Old 02-20-2017, 05:45 PM   #12
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
sudo update-alternatives --install /usr/bin/x-terminal-emulator x-terminal-emulator mate-terminal /usr/bin/mate-terminal 50
update-alternatives: priority must be an integer
http://askubuntu.com/questions/41964...isnt-installed

what is in bold should indicate that it is an executable f some type because it points to /usr/bin but when googling that very same word all I get are things about terminals and nothing about x-terminal-emulator itself.
 
Old 02-20-2017, 05:55 PM   #13
stanvan
Member
 
Registered: May 2007
Posts: 123

Rep: Reputation: 50
Quote:
Originally Posted by BW-userx View Post
http://askubuntu.com/questions/41964...isnt-installed

what is in bold should indicate that it is an executable f some type because it points to /usr/bin but when googling that very same word all I get are things about terminals and nothing about x-terminal-emulator itself.
Yes, it is a binary file in /usr/bin. I ran the config option for it and had 6 options available for other terminals, but not terminator. This is all default stuff in Lite as I haven't made changes.
 
Old 02-20-2017, 06:11 PM   #14
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by stanvan View Post
Yes, it is a binary file in /usr/bin. I ran the config option for it and had 6 options available for other terminals, but not terminator. This is all default stuff in Lite as I haven't made changes.
well I don't got that

but I did find this.

Code:
Set the terminal emulator

You can configure what terminal emulator PCManFM should use for Tools > Open Current
 Folder in Terminal under Edit > Preferences > 
Advanced e.g. bash -c 'pantheon-terminal --working-directory "$PWD"'.
towards the bottom of that post.

https://wiki.archlinux.org/index.php/PCManFM

Code:
bash -c 'terminator --working-directory "$PWD"'
but when I run it in pcmanfm using terminator it does not work, but if I use that in terminators cli it does work
Code:
(userx@SlackO⚡️~)>>$ terminator --working-directory ~/Downloads
opens another terminator
Code:
(userx@SlackO⚡️~/Downloads)>>$
so still not working


removed the " " around $PWD

Code:
bash -c 'terminator --working-directory $PWD'
now it is working

Last edited by BW-userx; 02-20-2017 at 06:16 PM.
 
1 members found this post helpful.
Old 02-20-2017, 06:18 PM   #15
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by stanvan View Post
Man, I type slow!
I usually type fast but when I do that my keyboard starts playing games on me and moves the keys around while typing so I hit the wrongs keys... ending up with tyops that I don't catch until after I post.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] PCManFM 1.2.3 - Custom commands: keep terminal open Michael Uplawski Linux - Software 4 02-29-2016 06:15 AM
Compile error in Terminal when I open Terminal in Ubuntu secman110 Linux - Software 2 10-29-2013 11:00 PM
how to run a terminal command that will open in a new terminal automatically floorripper Linux - General 5 06-18-2013 03:36 AM
[SOLVED] Change terminal for Thunar: 'Open Terminal Here' custom action.... andrew.46 Slackware 2 01-17-2012 05:46 AM
How to open programs in terminal without being stuck to the terminal?? brynjarh Linux - Newbie 6 07-07-2004 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration