LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-14-2017, 05:47 PM   #1
Nati323
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Rep: Reputation: Disabled
pavucontrol return to default when using the microphone


I have an issue with my laptop `Lenovo ideapad 310`

When I tried to record my self on `WhatsApp Web` I didn't hear anything except tiny noise.

So I searched in google and I found this answer https://askubuntu.com/questions/8783...ng-ideapad-310

The solution that suggested there helps me, but only temporary.

When I start to record the mircophone works fine, but after a second it returns to it's previous state, meaning default.

How can I make it permanent?

The solution that I used was to turn off one side of the input.

I also searched for that issue, found that https://askubuntu.com/questions/1669...nges-permanent but that another problem and the solution suggested there doesn't seems to help here
 
Old 07-14-2017, 07:21 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: IceWM on Debian
Posts: 5,490

Rep: Reputation: Disabled
HI

can you post the output to
Code:
aplay -l
99% of all modern pc have order as hdmi then analog but if you are never using hdmi, especially if you use a mic input you are better off turning hdmi

if you agree that is your situation then assuming you have intel sound do this please...open terminal

Code:
sudo echo 'options snd_hda_intel enable=0,1' > /etc/modprobe.d/intel.conf
2) full reboot and now open terminal and run

Code:
alsamixer -c0 -Vall
you should now what alsa thinks your sound levels should be for output and mic levels for input
---do not worry about headphone setting looking wrong at this stage as you probably have auto sense that allows the insertion of a headphone jack to bump volume up

(b) optional insert headphones and report if any change in headphone volume
--idealy we want your mic input not to pick up external speakers and have feedback across the line but its not important at this stage OK.

3) now start adjusting your mic input volumes to acceptable levels

my signature includes a mini howto but for your space bar activates the mic inputs and they will appear red
m key will mute or unmute volume outputs
page up/down or arrow up/down adjusts levels

4) when you are happy with current settings then we need to save those mixer levels and settings
so on reboot....we can restore them and resolve your main issue

I suggest we first create a mixer level file at your home dir like this

when your mic and output levels are correct
press the escape key to exit alsamixer then run command

Code:
sudo alsactl store -f ~/mixer.levels
this will store a file at /home/yourname

now full reboot

5) on reboot run

Code:
sudo alsactl restore -f ~/mixer.levels
alsamixer -c0 -Vall
and your mixer levels should show up as tested.

6) if you are using a distro that uses systemd, we may have to do things to get the service to work so it might help to name your distro

and check if your distro already has a rc.local service/file by

Code:
ls -al /etc/rc.local
systemctl list-unit-files | grep rc.local
if you are running a non-systemd system we can just edit the rc.local file
if you are running a systemd system we have more to do

7) so what is your distro and version please?
good luck

Last edited by aus9; 07-14-2017 at 11:36 PM.
 
Old 07-15-2017, 02:52 AM   #3
Nati323
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by aus9 View Post
HI

can you post the output to
Code:
aplay -l
99% of all modern pc have order as hdmi then analog but if you are never using hdmi, especially if you use a mic input you are better off turning hdmi

if you agree that is your situation then assuming you have intel sound do this please...open terminal

Code:
sudo echo 'options snd_hda_intel enable=0,1' > /etc/modprobe.d/intel.conf
2) full reboot and now open terminal and run

Code:
alsamixer -c0 -Vall
you should now what alsa thinks your sound levels should be for output and mic levels for input
---do not worry about headphone setting looking wrong at this stage as you probably have auto sense that allows the insertion of a headphone jack to bump volume up

(b) optional insert headphones and report if any change in headphone volume
--idealy we want your mic input not to pick up external speakers and have feedback across the line but its not important at this stage OK.

3) now start adjusting your mic input volumes to acceptable levels

my signature includes a mini howto but for your space bar activates the mic inputs and they will appear red
m key will mute or unmute volume outputs
page up/down or arrow up/down adjusts levels

4) when you are happy with current settings then we need to save those mixer levels and settings
so on reboot....we can restore them and resolve your main issue

I suggest we first create a mixer level file at your home dir like this

when your mic and output levels are correct
press the escape key to exit alsamixer then run command

Code:
sudo alsactl store -f ~/mixer.levels
this will store a file at /home/yourname

now full reboot

5) on reboot run

Code:
sudo alsactl restore -f ~/mixer.levels
alsamixer -c0 -Vall
and your mixer levels should show up as tested.

6) if you are using a distro that uses systemd, we may have to do things to get the service to work so it might help to name your distro

and check if your distro already has a rc.local service/file by

Code:
ls -al /etc/rc.local
systemctl list-unit-files | grep rc.local
if you are running a non-systemd system we can just edit the rc.local file
if you are running a systemd system we have more to do

7) so what is your distro and version please?
good luck
Hi, thanks for your answer.
Because my english isn't so good, I didn't understand all what you said.
So I'll ask a question to clear things.

This is the output from aplay -l

Code:
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20751/2 Analog [CX20751/2 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
I understand from this that I don't have hdmi, if so, should I do the other instructions you gave me?

I'm using Ubuntu 16.04 on Lenovo ideapad 310
 
Old 07-15-2017, 07:39 PM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Australia
Distribution: IceWM on Debian
Posts: 5,490

Rep: Reputation: Disabled
Hi

OK we try to solve this more slowly but first we must know where we are.

Quote:
I understand from this that I don't have hdmi
your aplay -l output shows that you appear to have only one card......card zero

you appear to have only one device on it that has analog sound.....device zero
and you have three hdmi devices.

so how many family members use this computer?

Are you the only user?


#####################################################################
step ONE
################################################################
to reduce confusion I will show only the system wide config file
copy and paste this into a terminal


Code:
sudo echo 'pcm.!default {
type hw
card 0
device 0
} 
' > /etc/asound.conf
then full reboot computer


then we move onto the next step which is to set up mixer levels

#################################################################
step TWO
#############################################################

Now as a local user open a terminal and copy and paste this command into it

Code:
alsamixer -c0 -Vall
step three
now take a screenshot of that terminal

step four
upload your image to
http://imgur.com/

click the green button = new post
choose your screenshot

wait a bit

step five at that imgur page
click the copy button on the right hand side

step six

paste the contents into your reply

I will show mine as a example
http://imgur.com/a/IvvnH

I will then look at it and offer more advice later

Last edited by aus9; 07-15-2017 at 07:54 PM.
 
Old 07-16-2017, 11:52 AM   #5
Nati323
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by aus9 View Post
Hi

OK we try to solve this more slowly but first we must know where we are.



your aplay -l output shows that you appear to have only one card......card zero

you appear to have only one device on it that has analog sound.....device zero
and you have three hdmi devices.

so how many family members use this computer?

Are you the only user?


#####################################################################
step ONE
################################################################
to reduce confusion I will show only the system wide config file
copy and paste this into a terminal


Code:
sudo echo 'pcm.!default {
type hw
card 0
device 0
} 
' > /etc/asound.conf
then full reboot computer


then we move onto the next step which is to set up mixer levels

#################################################################
step TWO
#############################################################

Now as a local user open a terminal and copy and paste this command into it

Code:
alsamixer -c0 -Vall
step three
now take a screenshot of that terminal

step four
upload your image to
http://imgur.com/

click the green button = new post
choose your screenshot

wait a bit

step five at that imgur page
click the copy button on the right hand side

step six

paste the contents into your reply

I will show mine as a example
http://imgur.com/a/IvvnH

I will then look at it and offer more advice later
Hi, thanks for your patience.

Here is the screenshot:

http://imgur.com/hBC6DDE
 
Old 07-22-2017, 11:39 AM   #6
Nati323
LQ Newbie
 
Registered: Jul 2017
Posts: 4

Original Poster
Rep: Reputation: Disabled
UP, Please help me
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Xubuntu 14.04 - Default panel removed. I Can't return it back to default mode. Jader Linux - Newbie 3 05-16-2014 10:50 AM
Set default return address for all mails sent from mailx thesunlover Linux - Networking 1 11-13-2012 07:12 AM
Return KDE to default t3st Linux - Software 3 03-21-2010 10:00 AM
how to return to default screen? karindiaconu Linux - Newbie 3 01-11-2008 01:14 PM
xset return to default after reboot bbmak Linux - Software 5 08-21-2004 03:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration