LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-02-2018, 08:01 PM   #1
voido
LQ Newbie
 
Registered: Jul 2014
Posts: 8

Rep: Reputation: Disabled
patch issues


Hello, I am trying to update squirrelmail with the compatibility patch and am getting an error. Was hoping for some help on this.

patch -p0 < /usr/share/squirrelmail/plugins/compatibility/patches/compatibility_patch-1.4.2.diff
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- ../../functions/strings.php.orig 2005-11-11 16:02:13.000000000 -0800
|+++ ../../functions/strings.php 2005-11-11 16:02:20.000000000 -0800
--------------------------


I have tried -p0 and -p1 but nothing works.

not sure what I am doing wrong here

thanks for any help.
 
Old 05-03-2018, 01:27 PM   #2
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,376

Rep: Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550
That's a pretty clear error message that says that the compatibility_patch-1.4.2.diff file is not in /usr/share/squirrelmail/plugins/compatibility/patches/

Where is the file actually located?
Code:
find / -name compatibility_patch-1.4.2.diff -ls
Use the correct path name to the file and patch -p0 should work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ns-2.35 gpsr-hls patch issues megha_18 Linux - Newbie 0 03-15-2016 07:44 PM
Issues trying to apply patch, uncertain of best route to proceed crypted Linux - Kernel 1 01-22-2013 03:10 PM
patch -p0 nvidia, 2.6.16, and FC5 issues. colonel Linux - Newbie 6 03-30-2006 02:23 AM
Patch issues with RH ES3 - understanding the rpm versions qljune Linux - Security 1 12-14-2005 10:31 AM
ut2003 v2225 patch and sound issues Abe_the_Man Linux - Games 0 01-12-2004 12:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration