-   Linux - Software (
-   -   Partition with fdisk fails!? (

nr5 01-11-2005 10:31 AM

Partition with fdisk fails!?

I get this message when i try to run fdisk /dev/hda

"You will not be able to write the partition table.
Note: sector size is 2048 (not 512)
Device contains nither a valid DOS partition table, nor Sun or OSF disklabel
untill you decide to write them. After that, of course, the previouse content wont be reconerable.

Warning: invalid flag 0x0000 of partition table will be corrected by w(rite)"

I have no idea what that means... And I cant create any partitions because they wont be saved after i write "w".

Im currently trying to install Gentoo on a DELL PowerEdge server... Anyone know how to fix this pls!?


nr5 01-11-2005 10:49 AM

Using cfdisk will give me the message "no permission to write" :(

WHY *cry*

homey 01-11-2005 11:05 AM

Are you doing this as root user?

nr5 01-11-2005 11:14 AM

I think so yes. One of my friends said that he thinks that fdisk is looking in a BIOS or something... but hes not sure...

Im really really stuck at the moment.. cant install anything :(

nr5 01-11-2005 11:18 AM

AHH!! I created a user and loged in as that user. Then when i write "su" and the password i get "su: Permission denied"?!?!

Maybe thats whats bugging the fdisk?

nr5 01-11-2005 11:37 AM

I should maybe add that I am booting from a CD now to install Gentoo... maybe its only looking at the CD volume?

Still in a sticky spot here.
Appreciate any help!

homey 01-11-2005 11:50 AM

Most installs are done as root user but I don't know what's going on. Does your bios see the drives ok? Do you have the drive jumpered as Primary Master?

nr5 01-11-2005 12:34 PM

everything is OK in bios. But i found something else thats bothering me...


when i write dmesg | less

I might add that my HD is a SCSI and not IDE.

homey 01-11-2005 12:48 PM


That kinda looks like the drives are not jumpered correctly.

nr5 01-11-2005 12:51 PM

what does jumbered mean?
I just got this server delivered... any idea how to fix this?


homey 01-11-2005 01:01 PM

Before things get really messed up, you should get a live body in there to help.
The hard drives and cdrom drives have jumpers ( switches ) on them which are used to set a drive as one of these.
Primary Master ( usually /dev/hda or first hard drive. Not a cdrom )
Secondary Master ( usually /dev/hdb or second hard drive Not a cdrom )

Primary Slave ( usually /dev/hdc or first cdrom drive )
Secondary Slave ( usually /dev/hdd or second cdrom drive )

If you have SATA drives, all of that can be totally different.

nr5 01-11-2005 01:25 PM

isnt there just a way for me find out what to use instead of "hda"? Thats sould be easy??

I tried the whole alfabeth with sdX (since i got a SCSI disk but none worked...)

nr5 01-11-2005 02:03 PM

okok i dont know HOW but it just started to work... thats the funny part...

anyway it works now =D


All times are GMT -5. The time now is 02:35 PM.