LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-20-2004, 03:22 PM   #1
black hole sun
Member
 
Registered: Jul 2004
Distribution: Slackware Current
Posts: 127

Rep: Reputation: 15
Unhappy Pango won't install because GLib >=2.4 is required!?


I'm at my wits end...

Pango 1.5.1, one of the dependencies of the latest GIMP program, will not install because it says the following when I ./configure

Code:
checking for GLIB - version >= 2.4.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** Glib 2.4.0 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
...and here's the relevant part of my config.log...

Code:
configure:21610: checking for GLIB - version >= 2.4.0
configure:21759: result: no
configure:21792: gcc -o conftest -g -O2 -Wall    conftest.c   >&5
conftest.c:27:18: glib.h: No such file or directory
conftest.c: In function `main':
conftest.c:33: error: `glib_major_version' undeclared (first use in this function)
conftest.c:33: error: (Each undeclared identifier is reported only once
conftest.c:33: error: for each function it appears in.)
conftest.c:33: error: `glib_minor_version' undeclared (first use in this function)
conftest.c:33: error: `glib_micro_version' undeclared (first use in this function)
configure:21798: $? = 1
configure: failed program was:
The thing is, I've installed Glib 2.5.0 - SEVERAL TIMES OVER just to make sure I did it right the first time! Why won't the Pango installer find it? I didn't install glib with any special options...just the same routine installation most other programs use.


I'm using Mandrake 10.0, as my profile says.

Help please

Last edited by black hole sun; 07-20-2004 at 03:30 PM.
 
Old 07-20-2004, 03:58 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
i assume you installed glib from RPM... if so install the glib-devel package too, or you're not installing a thing.
 
Old 07-20-2004, 04:04 PM   #3
black hole sun
Member
 
Registered: Jul 2004
Distribution: Slackware Current
Posts: 127

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by acid_kewpie
i assume you installed glib from RPM... if so install the glib-devel package too, or you're not installing a thing.
No, I installed from the tar.gz package.
 
Old 07-20-2004, 04:50 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
Code:
conftest.c:27:18: glib.h: No such file or directory
well it totally can't find it at all... you sure? you can always open up the configure script and find tat test, and recreate it yourself to see what's up. that check will be using pkgconfig, somewhere there will (if you did install from source) be a file, glib-2.0.pc, which is what is used for the detection. i'd guess that's not there.
 
Old 07-23-2004, 11:43 PM   #5
chis
LQ Newbie
 
Registered: Jul 2004
Distribution: Mandrake
Posts: 8

Rep: Reputation: 0
I've got the same problem

I've got *exactly* the same problem.

I've got a few problems:
1.) wanted to install GAIM 0.8 from source code, complains that gtk is not installed or whatever (actually, "locate gtk+-2.0.pc returns nothing...which worries me.........but I'm pretty sure mandrake 10 has gtk 2.0 or above....any solutions in where i can find gtk+-2.0.pc???)

2.) went to dl gtk+-2.4 tar.gz and install..........complains about glib not installed, version problem during ./configure

3.) went to install glib 2.4.4, no problems, very smooth (using ./configure, make and make install)

4.) went back to gtk and it STILL COMPLAINS!!!!

======================================================
[root@localhost gtk+-2.4.4] ./configure
...
checking for glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0... Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3

configure: error: Library requirements (glib-2.0 >= 2.4.0 atk >= 1.0.1 pango >= 1.4.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

[root@localhost gtk+-2.4.4]# echo $PKG_PATH_CONFIG
/usr/lib/pkgconfig

[root@localhost gtk+-2.4.4]# ls $PKG_PATH_CONFIG
alsa.pc fribidi.pc gnome-mime-data-2.0.pc libexif.pc libxine.pc openssl.pc xft.pc
audiofile.pc gedit-2.4.pc gobject-2.0.pc libexslt.pc libxml-2.0.pc vorbisenc.pc xrender.pc
esound.pc glib-2.0.pc gthread-2.0.pc libgphoto2.pc libxslt.pc vorbisfile.pc
fontconfig.pc gmodule-2.0.pc gtk-engines-2.pc libpng12.pc mad.pc vorbis.pc
freetype2.pc gnome-icon-theme.pc libart-2.0.pc libpng.pc@ ogg.pc xcursor.pc

** The GLIB version detected is 2.2.3, but i *did* install it (many times).
** gtk+-2.0.pc is absent
** glib-2.0.pc is present

========================================================


I know I didn't describe my problem very well...........but if anyone knows the solution, or tried it before and worked.............pls reply..........

Or if anyone can teach me the commands for detecting the current version of a particular software, pls reply as well....i need your help!!

thanks

chis
 
Old 07-24-2004, 08:14 AM   #6
eckerww
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
I'm having the same problem as well... though when I checked my config.log I saw a bunch of compiler errors. Have you guys checked your config.log files for similar conditions? It bugs me because I've compiled and installed a bunch of other programs and glib seems to be the only one that's having troubles. Are there environment variables or compiler settings that should be set before glib is compiled?

Wes

P.S. this is what I got on my installation attempt...

http://www.linuxquestions.org/questi...ndrake+10+glib
 
Old 07-24-2004, 08:28 AM   #7
chis
LQ Newbie
 
Registered: Jul 2004
Distribution: Mandrake
Posts: 8

Rep: Reputation: 0
...

*sigh*......

hopefully, some experts will come around and teach us.........

chis
 
Old 07-24-2004, 08:38 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
there really is no reason for you to try to compile gtk from source. just because you might wish to install an application using gtk from source, doesn't mean RPM's for GTK will work just super. just make sure you have all the relevant -devel libraries for gtk glib etc.. and you'll be fine.
 
Old 07-24-2004, 09:06 AM   #9
chis
LQ Newbie
 
Registered: Jul 2004
Distribution: Mandrake
Posts: 8

Rep: Reputation: 0
so...

are you suggesting that i need those devel packages even if i dl and compile from source code??

Or are you saying that we should find some rpm files (+ devel rpm ) and run it??

There are also an awful lot of dependencies problem with rpm...........how to solve those?

chis
 
Old 07-25-2004, 03:40 AM   #10
snellgrove
LQ Newbie
 
Registered: Jul 2004
Location: UK
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
same here!

Im having the same bloomin problem here! figured i'd come here and

Im trying to get GKrellm installed, and it said it needed GTK -Fair enough, I thought..so off I go, and get GTK 2.4 -the newest being 2.4.4, and it said it needed Glib. so I got, glib 2.4 (newest, again being 2.4.4 i believe -I never install the latest versions out, as im sure it'll probably break half my Linux!! ) and I install Glib, it said it went fine.. I check GTK again and ..huh?! what do you mean glib isnt installed!!

and doing a "pkg-config --modversion glib" it returns a rather shocking: 1.2.10
 
Old 07-25-2004, 06:32 AM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982Reputation: 1982
you want the -devel rpm's (which ARE on your distro cd's already waiting for you) instead of downloading any gtk source code.

dependencies suck... that's why i stopped using mandrake, although the urpmi tool on there does deal with a fair few of them quite well.
 
Old 08-10-2004, 09:59 AM   #12
opioid
Member
 
Registered: Jul 2003
Location: Chicago
Distribution: Ubuntu
Posts: 124

Rep: Reputation: 15
Fix

Acid, I don't know that giving the advice to forego source for binaries just because you don't have the answer is advisable. No offense intended.


Run the following as root:


PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
LD_LIBRARY_PATH="/usr/local/lib"
export PKG_CONFIG_PATH LD_LIBRARY_PATH


Voila!
 
Old 08-11-2004, 12:28 PM   #13
Ken-shin17
LQ Newbie
 
Registered: Jun 2004
Location: belgium
Distribution: slackware
Posts: 1

Rep: Reputation: 0
THx

that helped but the configure commands doesnt give errors anymore but i still can't comoile it with make

output :

/usr/lib/libgobject-2.0.so: undefined reference to `g_bsearch_array_destroy'
/usr/lib/libgobject-2.0.so: undefined reference to `g_bsearch_array_new'
/opt/pango-1.4.1/pango/.libs/libpangoft2-1.0.so: undefined reference to `g_type_instance_get_privat e'
/usr/lib/libgobject-2.0.so: undefined reference to `g_bsearch_array_insert'
/opt/pango-1.4.1/pango/.libs/libpangoft2-1.0.so: undefined reference to `g_type_class_add_private'
collect2: ld returned 1 exit status
make[4]: *** [pango-querymodules] Error 1
make[4]: Leaving directory `/opt/pango-1.4.1/pango'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/opt/pango-1.4.1/pango'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/opt/pango-1.4.1/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/pango-1.4.1'
make: *** [all] Error 2

root@ken-shin:/opt# ldconfig -v |grep gobject libgobject-2.0.so.0 -> libgobject-2.0.so.0.200.3
libgobject-2.0.so.0 -> libgobject-2.0.so.0.400.5


i was ganna make a nice question but i already solved it
I saw there are a lot of ppl having troubles with libraries soi'll give my solution.

dont have the same librarie laoded twice! that's what solved my problem, i just removed the one in /usr/lib and left the one in /usr/local/lib

hope i helped..



Last edited by Ken-shin17; 08-11-2004 at 01:08 PM.
 
Old 08-21-2004, 09:12 AM   #14
Adan
Member
 
Registered: Aug 2004
Location: Lithuania
Distribution: Debian 3.1rev1
Posts: 38

Rep: Reputation: 15
I have the same problem as Ken-shin17... If i try to compile pango using make it gives me a bunch of errors same as ken-shin's....
 
Old 08-25-2004, 01:09 PM   #15
Esrix
LQ Newbie
 
Registered: May 2004
Posts: 3

Rep: Reputation: 0
I've been running into the same problem- Pango does not want to install because it can't find the most recent dependencies after I install them. I also agree that simply looking for RPMs of the program you need are not the end all-be all solution.

In the most recent version of the GIMP tarbell packages I downloaded, it did mention that GIMP may not successfully install even after installing the newest version of ATK because it may detect an older version of ATK on the system. It recommends (and I kid you not) removing the old ATK libraries.

The reason I have not done so is because I'm afraid of the consequences. I'm afraid that if I did remove the old library and then tried to install, there might be some error that would keep me from using GIMP altogether. Which would mean I would have to re-install mandrake.

Surely, there must be another way to solve this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pango 1.4.0 and glib.h errors thehundredthone Linux - Newbie 4 03-28-2006 11:25 PM
Help!!! How to install GLib, GTK, ATK and Pango, just to get Firefox running. LOL RJARRRPCGP Linux - Newbie 7 11-20-2004 05:42 PM
Pango wants >=glib-2.4.0, I installed glib 2.4.7 and pango still says I need >=2.4.0 Locura Red Hat 5 11-01-2004 05:53 PM
Installing gtk,glib, pango af_dave Linux - Software 5 07-28-2004 03:48 AM
Pango-1.2.1 and GLib-2.2.1 Adam Shapiro Linux - Software 0 04-19-2003 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration