LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Pango and ATK not linking to correct Glib (https://www.linuxquestions.org/questions/linux-software-2/pango-and-atk-not-linking-to-correct-glib-166125/)

70k51k 04-04-2004 01:51 PM

Pango and ATK not linking to correct Glib
 
I am trying to compile GTK+ 2.4 so that I can compile the Gimp. Deb Packages are great but don't seem to come with gimptool so I can't install plugins. I am thinking that if I compile it from the source I will have the gimptool cause I can see gimptool.c and gimptool.h in the source.

Anyway, I managed to install Glib. It took me a while. I accidently installed Glib to /usr/local instead of /usr. I don't want to have two versions of Glib on my machine so I removed the one in /usr/local/. I reinstalled the latest version of Glib to /usr and manually removed the glib folders in /usr/local/. Now I have a problem though, when I try to compile ATK and Pango, it says it cannot find Glib above 2.2.0. When I run "$ pkg-config --modversion glib-2.0" it returns 2.4.0. I removed the glib-2.0.pc in /usr/local/lib/pkgconfig and made sure that the right one was in /usr/lib/pkgconfig. I ran "$ ldconfig" as root and still can't link to the right Glib. The config.log says that it cannot find glib.h. I am thinking that maybe it is still trying to access glib.h at /usr/local and not /usr. I could install GLIB to /usr/local but then I would have two versions of Glib to keep up.

Any help would be greatly appreciated.

AutOPSY 04-04-2004 04:02 PM

why dont you just install the binary package of Gimp.?

ababkin 04-04-2004 07:37 PM

i solved that problem by downloading latest glib RPM package


Alex

70k51k 04-05-2004 12:06 AM

Because the Debian package does not come with the gimptool executable. I want to use the perl plugins.


All times are GMT -5. The time now is 04:11 AM.