LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   pango 1.5.1 installation errors x.x (https://www.linuxquestions.org/questions/linux-software-2/pango-1-5-1-installation-errors-x-x-211497/)

Hawk2004 07-30-2004 11:46 AM

pango 1.5.1 installation errors x.x
 
Hey all, I am a Linux noobie so plz do help me out here..

I have been trying to get GTK+ 2.5.0 isntalled for a while now, and here are the dependancies I downloaded (the lastest at the time of this post):

pkgconfig-0.15.0
glib-2.5.0
atk-1.7.3
pango-1.5.1

and I have, as I said earlier, GTK+-2.5.0 as well.

I installed pkconfig first, it went ok, then I installed glib. So far so good, but when I tried installing atk it kept saying it couldn't find glib so I set the PKG_CONFIG_PATH like it suggested and that worked out fine. Then I got to pango, './configure' runs just dandy but when I try to 'make' it I get this:

Code:

/home/dave/Desktop/Unpacked/pango-1.5.1/pango/.libs/libpangoft2-1.0.so: undefined reference to `g_type_instance_get_private'/home/dave/Desktop/Unpacked/pango-1.5.1/pango/.libs/libpangoft2-1.0.so: undefined reference to `g_type_class_add_private'
/home/dave/Desktop/Unpacked/pango-1.5.1/pango/.libs/libpango-1.0.so: undefined reference to `g_unichar_get_mirror_char'
collect2: ld returned 1 exit status
make[4]: *** [pango-querymodules] Error 1
make[4]: Leaving directory `/home/dave/Desktop/Unpacked/pango-1.5.1/pango'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/dave/Desktop/Unpacked/pango-1.5.1/pango'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/dave/Desktop/Unpacked/pango-1.5.1/pango'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/dave/Desktop/Unpacked/pango-1.5.1'
make: *** [all] Error 2

Any ideas? :Pengy:

drake66 07-30-2004 12:51 PM

damnit, i'm new to this thing, its so damn frustrating when i get these 'recursive' errors like the guy posted in the topic
i have no clue how to fix it or get it to work

Hawk2004 07-30-2004 05:09 PM

*bump*

I am still unable to install this, and I have resintalled all dependancies many times now x.x What is wrong?


All times are GMT -5. The time now is 02:17 AM.