-   Linux - Software (
-   -   Package Config is unaware of several installed packages (

Sweyn78 02-22-2013 07:43 PM

Package Config is unaware of several installed packages
Hello! I'm trying to compile cairo with xcb support (because I have no life). I've noticed, though, that on all my compiles (not just cairo), I keep getting an error about missing libraries, but I have the libraries in question installed. I've tried reinstalling them with aptitude and directing whatever path is used by the compilation to where my library folders are, but the only thing that seems to work is when I compile all of the dependencies themselves from source, too. I don't really mind doing that too much, so that's what I did. But in order to finish compiling XCB, I need to compile Xinput, which is going to make me compile all of X11, which I kinda don't want to have to do because X11 likes to break when one messes with it. Or, at least it did when I ran Fedora. I generally try not to touch my X11 installation.
I have all of these requirements installed though (*-dev, of course), so it's fairly frustrating. I gave this several days of trial, but I realized that I do need to ask for help with this, so, hiya. :)
Necessary information:
^^ So, yes, I do have packageconfig set to the right directory.
I'm running Kubuntu 12.10. Why do I need cairo to use XCB if I don't use gnome? Most of my apps are GTK (well, gtk2). Also, I really like XCB. :P
So! How can I get Package Config or whatever to know where the *-dev libraries are installed?

John VV 02-24-2013 12:37 PM

cairo should have all the automake files in the source

run " make distclean"

autoreconfig -v -i
--- then ---
./configure ?????? options ??? and more options
make -j

i use all my cores on the cpu and " -j " tells it to use all of them
-- see the make man page

Sweyn78 02-24-2013 01:07 PM

Thanks, but no luck. It's still unaware that the XCB dependencies are installed. :\

Sweyn78 02-24-2013 01:17 PM

Fixed It!
Okay, so I don't know why I hadn't thought of this earlier, but I ran a recursive search in /usr for *.pc and found out where the bulk of them were located, and then appended that dir to the PKG_CONFIG_PATH variable. Things seem to be working, now. :D
Thanks! :)

John VV 02-24-2013 02:39 PM

on a 64 bit OS
$PKG_CONFIG_PATH =/usr/lib64/pkgconfig
and is normally auto set at time of install

Sweyn78 02-24-2013 04:57 PM

They ended up being here for me: /usr/lib/x86_64-linux-gnu/pkgconfig

Sweyn78 02-25-2013 02:25 AM

Yeah, I Guess the Problem Wasn't Solved Afterall. :\
As it turns out, I have *.pc files in some five dirs for some reason. Many of them are for the same package, yet contain different information. Meh. And the compiling is still having problems with not knowing that certain libs are installed (just with different libs this time). This is fairly annoying.
Does anyone know of a more graceful way to resolve this than symlinking all the pkgconfig dirs to one spot and overwriting a goodly number of duplicate (but not identical) *.pc files?

John VV 02-25-2013 03:00 AM

By chance were you building source code packages and somewhat installing them to random locations
" PKG_CONFIG_PATH " is normally


there might be a few in other places but they will be back up saved packages like the kernel source and gcc source

OPr if you built and installed programs to there OWN folder

now for example
If you build "out of sync" versions of programs
like say the TESTING version of gimp
then that build folder's ????/????/gimpTESTING/lib64/pkgconfig will need to be manually added to configure

but this is an extreme example

All times are GMT -5. The time now is 07:13 PM.