LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-19-2004, 02:21 AM   #1
justin_bloom
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
Angry oracle forms error frm-91111


I am having trouble getting forms 6i to work. When I try to run it, I get a frm-91111 error: window system startup failure.

I am using RH 9. I have Oracle 9i installed. I also have DS 9i installed; however, I do not like the way the web forms look, so I am now trying to get D2K 6i to work. I get the error when I try to run f60desm.

I have tried setting DISPLAY as localhost:0.0 (I am trying to use my system as both the client and server - hey, I'm just a poor student!) and simply :0.0 and neither solves the problem. I also tried to xhost +localhost and this makes no difference.

I have tried setting both ORA_NLS33 and ORA_NLS to $ORACLE_HOME/ocommon/nls/admin/data. I have NLS_LANG set to american_america.WE8ISO8859P1.

The only possible leads I could find was something about making sure there are no more than 256 colors set (I have no idea how to check/change anything like this). There was also something about a bug id 1413894 on metalink.oracle.com. However, you need some kind of support id to use this site, which I'm sure costs a lot of $$$.

IS THERE ANYONE OUT THERE WHO CAN HELP? PLEASE!

Thanks,
Justin
 
Old 03-19-2004, 04:51 AM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
can you even get X to start, if so DISPLAY :0.0 is not your problem,

also don't forget that when initializing a variable for the shell, export it.


export DISPLAY
 
Old 03-20-2004, 02:28 AM   #3
justin_bloom
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
X starts up fine. I am even able to bring up f90desm.sh, which is the Oracle DS9i version of the forms designer. I just can't get the D2K6i version of forms to work. It is an older version, and probably uses an older version of motif, but I imagine it is backward compatible. I'm stuck.
 
Old 08-08-2004, 04:31 AM   #4
idgl
LQ Newbie
 
Registered: Aug 2004
Location: Johannesburg
Distribution: RH 9.0 & Fedora Core 2
Posts: 2

Rep: Reputation: 0
I have experienced the same problem and did the following:
1) Installed the openmotif21 rpm
2) Edited $ORACLE_HOME/forms60/lib/env_forms60.mk to change the line
MOTIFLIBS=-L$(MOTIFHOME)lib $(MOTIFHOME)lib/libXm.so -L$(GUILIBHOME) -L$(GUILIBHOME) -lXt -lX11 -lm -lXp -lXext
to read
MOTIFLIBS=-L$(MOTIFHOME)lib $(MOTIFHOME)lib/libXm.so.2 -L$(GUILIBHOME) -L$(GUILIBHOME) -lXt -lX11 -lm -lXp -lXext
This forces forms60 to use the old motif 2.1 shared library libXm.so.2 instead of libXm.so.3
3) Relinked with
cd $ORACLE_HOME/forms60/lib; make -f ins_forms60w.mk install
This got rid of FRM-91111 for me.

Last edited by idgl; 08-08-2004 at 11:44 AM.
 
Old 06-17-2005, 05:54 AM   #5
usmans
LQ Newbie
 
Registered: Jun 2005
Posts: 1

Rep: Reputation: 0
oracle error

hello justin
can u tell me how did u install developer 6i and 9ids on redhat linux
i tried several times but i could not install these with oracle 9i already installed
plz tell me whole procedure,,, wht environment variables to set and wht steps to apply because 6i gives me linking errors... do i need some rpm packages to install them


regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oracle Error linux_pioneer Linux - Software 10 07-02-2005 01:23 PM
Oracle forms 6i RuudVV Linux - Software 2 05-17-2004 11:58 AM
Error on SuSE 9 when using Oracle dbca captainhog Linux - Software 1 04-06-2004 09:38 PM
Oracle Forms 6i seeone Linux - Software 0 03-01-2004 05:55 PM
Error while installing oracle 9i R2 on RedHat 8.0 leisure Linux - Software 0 03-24-2003 04:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration