-   Linux - Software (
-   -   Opera browser... little help (

ickselglic 03-09-2004 10:01 PM

Opera browser... little help
I downloaded the Opera browser and it will only load from the command line. I enter the same command in the execution field when I set up a new "link to application" but the hourglass just spins until it eventually times out... why won't it load when the icon is clicked?

kuhn 03-09-2004 10:40 PM

I know in order to get my desktop links to work correctly in KDE i have to name them "linkname".desktop where linkname is the name of the link. Also opera should make a link for itself in the /bin dir when it installs, so the execution path needs only to be 'opera' as this is already in your PATH environment variable.

Hope this helps.

ickselglic 03-09-2004 11:11 PM

But I downloaded the tar.gz and when I run it out of the terminal I do a ./opera in the Opera directory and it opens.... I tried what you said and that didn't work.

kuhn 03-09-2004 11:15 PM

Yeah sorry i installed from the rpm file for mandrake 9.2. Well the path to your opera dir should work...have you got the path in single quotes? e.g. '/usr/share/opera/opera'

ickselglic 03-09-2004 11:20 PM

I put it in quotes and tried again... it's funny because it will come up in my taskbar with an hourglass like it is going to load but then it just dissapears off my taskbar and nothing ever loads.... it's the exact same command i put in the terminal...

ickselglic 03-10-2004 08:18 AM

Anyone have any ideas?

Mega Man X 03-10-2004 08:27 AM

Try making a link. As root, type:

ln -s /path to where opera executable is.bin /usr/bin/opera

Then do as you did to create a the desktop icon: "link to application" yadda yadda yadda... but put only opera on the execution field ;)

Good luck!

ickselglic 03-10-2004 08:53 AM


What am I doing wrong here?

[root@localhost steve]# ln -s/home/steve/Opera/./opera.bin /usr/bin/opera
ln: invalid option -- /
Try `ln --help' for more information.
[root@localhost steve]# ln-s/home/steve/Opera.bin/usr/bin/opera
bash: ln-s/home/steve/Opera.bin/usr/bin/opera: No such file or directory
[root@localhost steve]# ln-s/home/steve/Opera.bin /usr/bin/opera
bash: ln-s/home/steve/Opera.bin: No such file or directory
[root@localhost steve]#

Mega Man X 03-10-2004 09:14 AM

cool. Try:

ln -s /home/steve/Opera/opera /usr/bin/opera

you might, in time, like to install programs in a better folder, like at /usr/local, to keep the system more organized, plus every user will be able to run programs located at /usr/local. (e.g: opera could be installed at /usr/local/opera ;))

ickselglic 03-10-2004 09:44 AM

Is there anyway that I can just redownload it and make it go into the usr/bin directory so that I can just type "opera" and have it work?

Mega Man X 03-10-2004 09:46 AM

I'm not familiar with Opera (I've used with Libranet, but did not like it). But the above procedure would work. Basically, download it, uncompress to /usr/local, make a link with ln -s /usr/local/opera/opera /usr/bin/opera and it should start by typing opera only :)

All times are GMT -5. The time now is 01:39 AM.