LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-24-2017, 09:29 AM   #1
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Rep: Reputation: Disabled
Opera


Hello.
Whenever I open Opera, it pops up a message asking for a password.
How to make a password prompt?
Regards
 
Old 06-24-2017, 05:32 PM   #2
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by Longines View Post
Hello.
Hi.

Quote:
Originally Posted by Longines View Post
Whenever I open Opera, it pops up a message asking for a password.
Do you know what exactly the password is for or why it's asking for one? Does it have anything to with this?

Quote:
Originally Posted by Longines View Post
How to make a password prompt?
I'm not sure what you mean here.

Regards
 
1 members found this post helpful.
Old 06-24-2017, 05:42 PM   #3
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Original Poster
Rep: Reputation: Disabled
How do I run the Opera browser to ask for a password?
Obviously, it is a password such as when installing the system. If I enter the password the browser starts. I think writing a password to run a browser is an exaggeration. Now you understand my problem.
 
Old 06-24-2017, 06:01 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,412
Blog Entries: 28

Rep: Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409
Just to be clear, what you want is for the browser itself to be password-protected so that someone must enter a password in order to use the browser. Is that a correct understanding?
 
1 members found this post helpful.
Old 06-24-2017, 06:11 PM   #5
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by Longines View Post
Obviously, it is a password such as when installing the system. If I enter the password the browser starts. I think writing a password to run a browser is an exaggeration. Now you understand my problem.
Hi...

Just to confirm, is Opera asking for the password or your operating system? If Opera, did you set the Master Password, by any chance? If so, you might be able to disable it in "Preferences." If the operating system, what distribution and version of Linux are you running and what desktop environment are you using? What application is asking for the password?

Regards...

Last edited by ardvark71; 06-24-2017 at 06:13 PM. Reason: Correction.
 
1 members found this post helpful.
Old 06-25-2017, 02:47 AM   #6
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Original Poster
Rep: Reputation: Disabled
Never before, no browser asked for a password. During installation of Opera I did not enter any passwords. After installing Opera and launching it prompts for a password. So I type the password I set up when I installed the system (Ubuntu 16.04 LTS). Only after entering the password will the browser start.
What's more interesting is how I press "cancel" button once, then the browser starts without password. I just do not want to be prompted for a password. When running Opera.

Regards
 
Old 06-25-2017, 04:01 AM   #7
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Original Poster
Rep: Reputation: Disabled
That's how it looks.

Translation:
Unlocking account keys.
Please enter a password to unlock the account key database.
Account key database was not automatically unlocked when signing in to this computer.

https://www.dropbox.com/s/tltci96570...52-46.png?dl=0

Last edited by Longines; 06-25-2017 at 04:16 AM.
 
Old 06-25-2017, 07:42 AM   #8
un1x
Member
 
Registered: Oct 2015
Posts: 645

Rep: Reputation: Disabled
...
 
1 members found this post helpful.
Old 06-25-2017, 10:12 AM   #9
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by Longines View Post
Hi...

Could you translate this into English for us, word for word?

EDIT: Whoops, you already did. Thanks!

Regards...

Last edited by ardvark71; 06-25-2017 at 10:14 AM. Reason: Correction.
 
1 members found this post helpful.
Old 06-25-2017, 10:22 AM   #10
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by Longines View Post
That's how it looks.

Translation:
Unlocking account keys.
Please enter a password to unlock the account key database.
Account key database was not automatically unlocked when signing in to this computer.

https://www.dropbox.com/s/tltci96570...52-46.png?dl=0
Hi...

Do one of these solutions help address the problem?

https://askubuntu.com/questions/867/...eyring-on-boot

https://askubuntu.com/questions/3178...ing-on-startup

https://askubuntu.com/questions/1842...-get-rid-of-it

Regards...
 
1 members found this post helpful.
Old 06-25-2017, 10:33 AM   #11
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,818

Rep: Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978
Quote:
Originally Posted by Longines View Post
That's how it looks.

Translation:
Unlocking account keys.
Please enter a password to unlock the account key database.
Account key database was not automatically unlocked when signing in to this computer.
If I had to guess, you're using automatic login, correct?? Your Gnome keyring for credential/keys isn't being unlocked, so Opera (by default, I believe), uses it to store passwords for websites. You can address this one of two ways:
  • Disable automatic login to your Linux desktop. Entering your password will unlock the keyring on login, and message goes away.
  • Modify the Opera shortcut to have "--password-store=basic" at the end; there may be an option in Opera to switch which keyring/database it uses, but this runtime flag forces it to use its own credentials storage mechanism, and your system keyring is ignored.
 
1 members found this post helpful.
Old 06-25-2017, 11:26 AM   #12
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Original Poster
Rep: Reputation: Disabled
Nothing helped.
Password reset - did not solve the problem.
Disable auto login - did not solve the problem.

It looks like Opera has written down a master password somewhere and is still remembering it. So even deleting a password does not solve the problem. You probably have to uninstall Opera and reinstall. But it also will not be certain that the password settings will be omitted during the uninstallation of Opera.
 
Old 06-25-2017, 12:16 PM   #13
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,818

Rep: Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978
Quote:
Originally Posted by Longines View Post
Nothing helped.
Password reset - did not solve the problem.
Disable auto login - did not solve the problem.
..and did you try starting Opera with the switch given?
Quote:
It looks like Opera has written down a master password somewhere and is still remembering it. So even deleting a password does not solve the problem. You probably have to uninstall Opera and reinstall. But it also will not be certain that the password settings will be omitted during the uninstallation of Opera.
Nope, this isn't to do with Opera. It's asking for your keyring password. You can set your keyring to stop asking for a password, start Opera with the switch given to keep it using local credentials storage. Or, you can try renaming the folder $HOME/.local/share/keyrings to $HOME/.local/share/keyrings.old and a restarting.
 
1 members found this post helpful.
Old 06-25-2017, 12:44 PM   #14
Longines
Member
 
Registered: Sep 2016
Location: Poland
Distribution: www.romancatholic.hoste.pl
Posts: 58

Original Poster
Rep: Reputation: Disabled
I can not rename the keyrings. How to do it?.
 
Old 06-25-2017, 12:58 PM   #15
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,818

Rep: Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978Reputation: 6978
Quote:
Originally Posted by Longines View Post
I can not rename the keyrings. How to do it?.
Since you don't tell us what you've done/tried or what problems you've encountered, we can't really tell you how to resolve them. Should just have to type in "mv" to move them to a different name, just as said before:
Code:
mv $HOME/.local/share/keyrings $HOME/.local/share/keyrings.old
...from a terminal window, logged in as your 'regular' user, not root or sudo. Again, though, setting your keyring to not ask for a password works, as does starting Opera with the switch you've been given. Resetting your password is pointless, since not providing it to the keyring is what the message is about.

Here is a link from the Ubuntu forums for 16.04 that's not many years old for a different version than you have:
https://askubuntu.com/questions/7919...chrome-keyring
 
1 members found this post helpful.
  


Reply

Tags
opera


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Opera 36.0 Gets New Build, Brings Personalized News and a Simplified Opera Menu LXer Syndicated Linux News 0 01-29-2016 02:36 AM
To the guy who works for Opera, RE: Rumors of Facebook acquiring Opera spudgunner General 16 06-02-2012 08:44 PM
LXer: Opera Desktop Team releases first Unix builds of Opera 10.5 LXer Syndicated Linux News 0 01-01-2010 09:11 AM
LXer: Opera Launches Final Version of Opera 10 Browser LXer Syndicated Linux News 0 09-02-2009 02:20 PM
installing 32bit opera after installed 64bit opera soa Linux - Software 1 08-13-2008 06:51 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration