-   Linux - Software (
-   -   OpenVPN build LZO not found (

libsys 07-14-2005 01:34 AM

OpenVPN build LZO not found
I'm having problems getting openvpn 2.0 to build with LZO support. At first, I didn't have the LZO library installed, so I downloaded the source and installed it. Unfortunately, the openvpn configure script still can't find the libraries or headers.

I searched for the files that openvpn was looking for, and found them in /usr/local/include and /usr/local/lib. I've added these paths to /etc/ and run ldconfig, but still no luck configuring openvpn, it just comes back with:

configure: checking for LZO Library and Header files...
checking lzo1x.h usability... no
checking lzo1x.h presence... no
checking for lzo1x.h... no
LZO library and headers not found.
LZO library available from
configure: error: Or try ./configure --disable-lzo

I have tried configure both with and without "--with-lzo-headers" and "--with-lzo-lib", I've also tried symlinking the lzo libraries and headers to /usr/lib and /usr/include respectively, still without getting it working.

Does anyone have any idea how to resolve this?

madluther 07-14-2005 06:53 PM

which version of lzo did you install , 1.08 or 2.01 ? openvpn requires 1.08 . Did you try to disable it with configure by parsing --disable-lzo ?

libsys 07-14-2005 09:07 PM

Hmmm, yeah I did try installing a 1.08 binary, but still got the same error. I've tried the --disable-lzo setting and this worked - in what way will this affect my build of openvpn? I imagine lzo reduces the bandwidth or traffic that openvpn uses, is this the case?

madluther 07-15-2005 06:17 AM

Without lzo the tunnel may use more bandwidth, but for it to be effective both ends of the tunnel have to support it. If you were able to compile lzo 2.01, the older version should build fine, look for it here, . The binary version probably doesn't include the devel headers, libs and scripts that you need.

libsys 07-15-2005 08:54 AM

Looks like you were right...I removed the rpm, installed 1.08 from source and openvpn configured and built without a hitch.

Many thanks!

All times are GMT -5. The time now is 01:50 AM.