-   Linux - Software (
-   -   OpenSSL version and version mismatch (

pbidwell 08-09-2012 05:18 PM

OpenSSL version and version mismatch
Hi all,

I'm cross-compiling the latest (1.0.1c) version of OpenSSL. The entire process goes well, but for some reason, the two lib files come out as and The new version of OpenSSL seems to run well also with no real problems.

I grabbed another virgin copy of the 1.0.1c OpenSSL tarball, and it seems that the SHLIB_VERSION numbers are hardcoded into as 1.0.0.


1. What is the reason for this? I've looked through the provided documentation, but I do not see any discussion of the library version numbers being different.

2. How can I change it? It has the potential to confuse the other engineers I work with. I tried to change the values in, but when I try to see the SSL and SSH version, I get the typical "OpenSSL version mismatch. Built against XXXXXX, you have YYYYYYY".


knudfl 08-11-2012 03:18 AM

Welcome to LQ.

All versions, openssl-1.0.x.x : The 'names' are lib***.so.1.0.0

Why would you want to change the name ?


pbidwell 08-11-2012 10:50 AM

Thanks for the quick reply.

We are upgrading from version 1.0.0 to 1.0.1, and the fact that the library names don't change with the OpenSSL upgrade just makes it a bit more difficult to tell if we are using the new libs or not.

If this is simply the way OpenSSL does it, I won't bother with trying to change it.

Thanks again, marking as solved.

knudfl 08-11-2012 11:34 AM

Well, it wouldn't be very convenient,
if the 'so name' changed for every update.

Then you'd also have to recompile the "300" libraries
and applications depending on*,*.


All times are GMT -5. The time now is 06:42 AM.