LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-07-2004, 01:17 AM   #1
cgoerner
Member
 
Registered: Apr 2004
Location: South Australia
Distribution: Ubuntu & Debian Sarge
Posts: 32

Rep: Reputation: 15
openoffice slow to start


I'm running a fairly standard install of Fedora Core 2 on a P4 1.4GHz, 384MB RDRAM, 80GB 7200RPM barracuda.
Open office takes 30 seconds to start. It takes 10 second before the splash screen is displayed. Also, the first time I right-click on a misspelled word, it also takes about 30 seconds to display the menu of suggestions.
Could this be a hard drive issue, how could I check?

This doesn't seem to be isolated the this system or distribution. I've tried it with other systems running FC2 and RH9 with similar results.

What would be causing this, and what could I try to speed things up a bit.

Other GUI apps can be quite slow too. I'm using gnome, so when I run KDE apps, it can take quite a while before anything is displayed. The strange thing is that the CPU usage is low most of the time.
Once the programs are started, they're very responsive... it's just the starting that's slow.
Gnome apps are a bit more snappy but still take a few seconds to start.

Any help would be greatly appreciated
 
Old 08-07-2004, 03:28 AM   #2
Le_coyote
LQ Newbie
 
Registered: Aug 2004
Location: France
Distribution: Mandrake 10.0 (2.4.25-2mdk)
Posts: 23

Rep: Reputation: 15
openoffice is well known to take all the ressources of the computer. the last version (1.1) is yet faster than the 1.0.
but that's very strange. my ooo takes 15sec maxi to be ready. are you sure to have the correct version for your distribution ?
if you got isdn, download the last version here

the system requirements for linux :
- Glibc 2.2.0 or newer
- Pentium compatible PC, 64 MB RAM, 300 MB available hard disk space
- X server and graphics card capable of 800x600 resolution
 
Old 08-07-2004, 04:22 AM   #3
cgoerner
Member
 
Registered: Apr 2004
Location: South Australia
Distribution: Ubuntu & Debian Sarge
Posts: 32

Original Poster
Rep: Reputation: 15
I've got:
openoffice.org-1.1.1-4 (the version that came with my FC2 distro)
glibc-2.3.3-27
geforce 2 mx with nvidia drivers installed
kernel-2.6.6
7.6GB free on my / partition (/dev/hdb2)

Code:
# /sbin/hdparm -tT /dev/hdb
 
/dev/hdb:
 Timing buffer-cache reads:   1820 MB in  2.00 seconds = 910.14 MB/sec
 Timing buffered disk reads:  102 MB in  3.04 seconds =  33.52 MB/sec
Not sure if that's normal.
33mb/s can't be bad.

I'll download 1.1.2 and see if that makes a difference.
I haven't got isdn ... but I'll fire up d4x and wait a day or two

Thanks
 
Old 08-07-2004, 09:26 AM   #4
robbow52
Member
 
Registered: Oct 2003
Location: Kentucky, USA
Distribution: Debian "SID"
Posts: 110

Rep: Reputation: 15
Re: openoffice slow to start

Quote:
Originally posted by cgoerner
I'm running a fairly standard install of Fedora Core 2 on a P4 1.4GHz, 384MB RDRAM, 80GB 7200RPM barracuda.
Open office takes 30 seconds to start.

What would be causing this, and what could I try to speed things up a bit.

Any help would be greatly appreciated
I don't know if it's available for your distro or not, but the ooqstart applet for gnome (OpenOffice.org Quicstarter, gnome-ooqstart in Debian) speeds things up a lot on my system (Debian). You do have to "enable" it once its installed but my launch times for OpenOffice went from 10-12 seconds to probably less than a second for the various applications! It of course is one more process running on your system...

Just a thought!
 
Old 08-07-2004, 06:32 PM   #5
cgoerner
Member
 
Registered: Apr 2004
Location: South Australia
Distribution: Ubuntu & Debian Sarge
Posts: 32

Original Poster
Rep: Reputation: 15
Thanks, I'll give that a go
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice 2.0 is very slow to launch tongliu8 Linux - Software 24 12-24-2010 12:13 PM
OpenOffice is slow!! akudewan Linux - Software 3 05-10-2005 03:48 AM
Very Very Slow OpenOffice getting on my nerves... Gormless Linux - Software 4 10-30-2004 12:08 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 08:53 PM
System uncleanly shut down, ran e2fsck, very slow start & slow desktop brakthepoet Linux - Newbie 1 07-02-2004 01:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration